How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Mercedes
Satisfied Customers: 21865
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Mercedes Question Here...
Matt is online now

hello i wonder if you could help iv got a 56 plate c200 coupe

Customer Question

hello i wonder if you could help iv got a 56 plate c200 coupe and every time i accelerate there is a loud blowing noise there is no lack of power and iv had it into a normal garage and they have said they couldnt see anythin even with the bumper off to check the intercooler, any ideas
Submitted: 4 years ago.
Category: Mercedes
Expert:  Matt replied 4 years ago.
Hello

I'd first check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues
Also have a feel around with your bare hands with the engine running to see if you can feel any escaping gas under your touch. Another method is to use a soap and water solution sprayed onto any suspect areas - if there's a leak it'll bubble up with the engine running

If this is OK then remove the high pressure intake hose after the turbo and have a feel of the turbine wheel - there should be no play radially at all - but a little bit of axial / end to end float is normal

one other possibility is that the wastegate actuator spring has gone soft so allowing the wastegate to open prematurely - if your actuator has a threaded end you can increase the preload on it to see if this improves things otherwise these units are quite cheap compared to a new turbo so it may be worth trying a replacement

If this is OK then check for air leaks after the mass airflow meter - The best way to locate a leak is to have the engine running and warm and then spray lighter gas /propane around each joint in turn. If the engine rev's up you've found your leak.
Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.