How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Mercedes
Satisfied Customers: 22143
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Mercedes Question Here...
Matt is online now

I have a mercedes c200 kompressor (s203). The engine management

Customer Question

I have a mercedes c200 kompressor (s203). The engine management light has come on and the tickover is really rough. What could the problem be?
Submitted: 4 years ago.
Category: Mercedes
Expert:  Matt replied 4 years ago.
Hello

On any car if you get a check engine light or other fault light this typically means one or more of the sensors has failed or has a faulty connection.

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method.

from your description I 'd say that this could be an airleak after the airflow meter, any air dragged in here isn't 'seen' by the ECU and so not compensated for and can lean the engine out and can also allow the engine to rev up when not desired causing rough running.
As its a mechanical fault it tends not to turn on the fault light and you can sometimes hear a 'hissing' noise with the engine running.

Check the hose clips for tightness and inspect the trunking for any cracks or splits and also all the vacuum system, the small bore pipes and fittings for cracks and missing parts.

The best way to locate a leak is to have the engine running and warm and then spray lighter gas /propane around each joint in turn. If the engine rev's up you've found your leak.
Now you might think that spraying lighter gas around a hot engine isn’t wise, however the flash /ignition point of gas is about 400°C so you need a naked flame or spark to set it off and I’ve used this method for many years without incident.
Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.