How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Mercedes
Satisfied Customers: 528
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Mercedes Question Here...
Matt is online now

Multi function display not displaying correctly

Customer Question

I have a 2005 Mercedes C200, the multi function display on the dash board stopped working properly. It displays correctly (black background with white writing) when I put the key in the ignition, but once I start the engine the whole display starts to go white then becomes unreadable. The drivers footwell in my car was wet at the same time, I think this was because the drain on the bonnet was blocked, I have sorted this now but can't find a trace of where the water came from so don't know if this is a coincidence or not. Any ideas?
Submitted: 3 years ago.
Category: Mercedes
Expert:  Shantal-Mod replied 3 years ago.

Hello,

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you,

Shantal

Customer: replied 3 years ago.
The problem seems to have resolved itself now, I'm not sure whether some water got into it because the windscreen drain was blocked. Since this morning It is working fine now though so please cancel the question