How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike_a_mechanic Your Own Question
mike_a_mechanic
mike_a_mechanic, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 5470
Experience:  17 years experience as a auto mechanic, foreign and domestic.5 years running my own repair business.
19374685
Type Your Mercedes Question Here...
mike_a_mechanic is online now

HI i have a petrol A140, car ran one week ago, no probls, all

Customer Question

HI i have a petrol A140, car ran one week ago, no probls, all electrics are now dead, and even with a jump no electrics, nuffin, nada... help
Uel
Submitted: 3 years ago.
Category: Mercedes
Expert:  mike_a_mechanic replied 3 years ago.
Hello, welcome. My name is Mike, I will do my very best to assist you with your question. I apologize if you have been waiting long for a response.

From what you are describing this issue is a ground problem, without a good secure ground there will be no power even with a good battery.

Start be following the battery cables from the battery to the starter and the battery to the alternator and block and make sure that all connections are secure, tight and with no corrosion.