How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, UK Qualified Car Technician
Category: Mercedes
Satisfied Customers: 4623
Experience:  Fully qualified / self employed garage technician in the UK
13210289
Type Your Mercedes Question Here...
Robert is online now

Hi, have an ml320. Tried to start this morning and when turned

Customer Question

Hi, have an ml320. Tried to start this morning and when turned the ignition key the dashboard display flickered, there was a 'chattering' noise that sounded like a relay switch flicking repeatedly on and off and an audible beeping alarm. All these have now stopped and there is no display at all when the ignition key is turned, vehicle completely dead. Battery?
Submitted: 2 years ago.
Category: Mercedes
Expert:  Robert replied 2 years ago.

Hi..

Hopefully i can help..

If all electrical items have stopped working - then yes it most likely the battery has lost voltage or there isnt enough to enable turning the engine over hence the chattering - first things to check really are the battery terminals and ensure they are tight and show no signs of corrosion..next is if you have access to a jump starter/booster pack - jump leads and another car to provide power - connect this via the jump start points undr the bonnet "details in the manual id imagine" or jump at the battery itself..and see if that gets the car running..if it does then you need to ahave the battery checked itself/load tested and its state as well as the charging system and or anything causing a drain on the battery if the battery is replaced and this problem still occurs..if the battery is pretty much older than 5 years roughly then it likely the battery is past its best and requires replacement..but as above try the jump start method first...I do hope this helps