How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Mercedes
Satisfied Customers: 21855
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Mercedes Question Here...
Matt is online now

I just purchased a mercedes C200 auto estate Cdi 2004 model..

Customer Question

Hi. I just purchased a mercedes C200 auto estate Cdi 2004 model.. On the way home I stopped at a toll bridge then as i was pulling off the power seemed to go. the box was still changing up...but power seemed to have dropped right down, and the kickdown also wasnt happening. I used the tiptronic shift to drop the gear but again the power had seemed to have dimished. And even at a higher rev the power had gone...The temp was ok just running a little under the middle of the guage.
Any advice appreciated.
Submitted: 2 years ago.
Category: Mercedes
Expert:  Matt replied 2 years ago.

Hello



This could be a lack of fuel pressure from the electrical pump at the tank.

If the connections to this are corroded or damaged then the pump could stop at any time or could not be running at full speed. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse,
Ideally measure the pressure at the inlet to the main engine fuel pump and if this is low check the pump as described and also consider changing the fuel filter as if this partially blocked this too will reduce pressure.

If both of these are OK then also check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If its a variable vane turbo (they’ll be an actuator on the turbo body - but not a wastegate) then check its vacuum pipework as above and check the connections to the diaphragm / solenoid valve

Also worth checking that the glow-plug relay is switching off as they can stick on and leave the glow plugs also on - on some cars this can force it into limp home

Also worth considering adding a bottle of injector cleaner into the tank as a clogged injector nozzle will reduce powerand give poor combustion - the next stage on from this is to remove all the injectors and have them ultrasonically cleaned and flow checked

Also check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

Expert:  Matt replied 2 years ago.
Hi

do you still need help?