How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 53901
Experience:  Bosch Certified Master Technician with over 35 years experience in the automotive industry.
13230946
Type Your Mercedes Question Here...
Marty is online now

I was driving to work and the both rear windows started

Resolved Question:

Hi I was driving to work and the both rear windows started to operate and front wipers started without being switched on, the wipers will stop in different positions and then stop working until the ignition is turned off and then back on only to repeat the same actions, there was some burning smell coming from both window motors which have now been disconnected, there is also a brake wear alarm on the display but there was new brakes fitted 4mths ago, I've disconnected the battery for a short time but nothing is working.
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.
Hi, welcome to Just Answer. My name is***** sounds like you have a shorted body control module. This is usually caused by water intrusion into the module. What is the year and model of your car?
Customer: replied 1 year ago.
Hi it's 2007 MERCEDES ML 320 4MATIC CDI
Expert:  Marty replied 1 year ago.
Ok, the common problem on that model is water intrusion into the rear signal acquisition module. The module is located in the cargo compartment below the fuse box. I've attached a picture below.
Customer: replied 1 year ago.
Hi I will check this out tomorrow in the daylight and let you know my findings, Cheers
Expert:  Marty replied 1 year ago.
You're quite welcome.
Customer: replied 1 year ago.
Hi Marty Thanks for the help removed the sam and found some corrosion, cleaned the connectors, and wipers are working fine and alarms cleared, as for the rear windows the constant power supply as stopped so no more smoking, tried a reset and i can hear some clicking but unfortunately the windows won't operate, don't know if I have burnt the motors out now. Is there a fuse or relay I can look at as there's no location in my fuse plan. Many Thanks
Expert:  Marty replied 1 year ago.
Hi, there are no separate fuses for the windows. The window motors are protected by the front SAM. I would check the battery compartment for water intrusion. The front SAM is located in the battery compartment. If water got to the front SAM it would cause problems as well. The battery is located under the passenger front seat.
Expert:  Marty replied 1 year ago.
If you have a RHD car the battery may be under the driver's seat.
Expert:  Marty replied 1 year ago.
Let me know how you make out.Marty
Customer: replied 1 year ago.
Hi Again Checked out the sam under the driver seat and all ok, removed window motor and found it to be melted, will have to order 2 new ones, Thank you so much for your help.
Expert:  Marty replied 1 year ago.
You're quite welcome.
Expert:  Marty replied 1 year ago.
If you would please take a moment to rate my service on this question I would appreciate it.
Marty and other Mercedes Specialists are ready to help you

Related Mercedes Questions