How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, ASE Certified Technician
Category: Mercedes
Satisfied Customers: 54023
Experience:  Bosch Certified Master Technician with over 35 years experience in the automotive industry.
13230946
Type Your Mercedes Question Here...
Marty is online now

We have a Mercedes 230 SLK, 2003, with 40,000 miles on the

Customer Question

Hi We have a Mercedes 230 SLK, 2003, with 40,000 miles on the clock. We have had this two years. When the car gets wet from either washing it or in heavy rain, water seems to be getting some of the electrics. The dials flick up and down, the lights on the dashboard come and off, it bulks when selecting Drive, and if turn off will not start for some minutes, the key is turned but just clicks. the Engine management light comes on and stays on, some time the BAS light comes on and stays on. The fan also seems to be going at full speed whilst all this is going, then when left for a few minutes it will be fine, until the next time you take it out. This has something to do with water getting somewhere as it only happens in rain and wet conditions, we have put a new battery in, we have replaced the bulk head seal between the bonnet and the bulk head. we have noticed water does come into the engine department and also around the battery. we can find a battery cover to protect from the rain, could this be the problem? Any ideas? Kevin
Submitted: 1 year ago.
Category: Mercedes
Expert:  Marty replied 1 year ago.
Hi Kevin, my name is***** sounds like water may be getting into the K40 relay module. The module is located in the module box next to the battery. I've attached a picture below. The K40 module powers the items that are malfunctioning. I'd inspect the area and see if there are signs of water intrusion.Let me know if you have any questions. Please remember to rate my service in order for the website to credit me for taking your question.Marty
Customer: replied 1 year ago.
Marty - thanks, ***** ***** investigate further and get back to you.
Expert:  Marty replied 1 year ago.
You're quite welcome.
Marty and other Mercedes Specialists are ready to help you
Customer: replied 1 year ago.
Hi Marty - just checked the K40 area, taken it right out and all is dry, there is no sign of mositure there, the printed circuit board look good, no rust or burnt points etc, any other ideas where water may be causing these issues? Kevin
Expert:  Marty replied 1 year ago.
Hi Kevin, sorry about the wait I never saw this reply. How are you doing with the car?
Customer: replied 1 year ago.
Hi Marty, as mentioned above, no mositure or water in the K40 area. When raining or car washing, water is causing a problem. I can't see and visiable water traps. are there any other areas that would cause the symtons already mentioned. I will get the dianostics checked and the EM light is still on. Where else can water into?Thanks
Expert:  Marty replied 1 year ago.
I think what I would do is hose down the car in certain areas to try and reproduce the problem. Try just wetting the front of the car and see if the problem occurs. The K40 is the most likely cause of this problem. I would suggest swapping out the K40 with a known good relay and see if it solves the issue. All of the items that are malfunctioning pertain to the K40 relay. The only other thing that I can think of is that water may be getting into the PSE module located in the trunk. The PSE module controls the locks and anti theft system. I'd inspect the lower trunk and the module for signs of water intrusion. I've attached a picture below.