How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Mercedes
Satisfied Customers: 22241
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Mercedes Question Here...
Matt is online now

I have a Mercedes Vito 113 CDI Taxi 2012. When i put it into

Resolved Question:

Hi
I have a Mercedes Vito 113 CDI Taxi 2012. When i put it into reverse or drive i get a bid vibration and shaking for a couple of seconds and then it drives fine. This happens almost every time I put it into gear and has also cut out a few times. My garage have put the diagnostic machine to test this but no faults are showing.
Submitted: 22 days ago.
Category: Mercedes
Expert:  Matt replied 21 days ago.

Hello

Id 1st check for worn mountings - check the tightness of the engine and gearbox mounts and their condition - this is best done by using a jack to take the weight of the engine off the mounts and seeing if any cracks or splits open up in the rubber.Also check the tightness of the mounts bolts

If this is OK then I'd bleed the clutch hydraulics and ensure that you replenish the all fluid in the system and get any trapped air out

I favour having a clear hose from the nipple to a jar 1/2 full of old fluid and with the nipple closed your assistant pushes the pedal up and down a few times, then holds it down whilst you then crack open the nipple and close it again whilst fluid is still flowing.

My goal is to give you the best advice that I can and I hope that I've helped today. Please remember to rate my service by selecting from the 5 stars at the top of the screen before you leave. If you need more help, use the reply box to let me know.

Customer: replied 21 days ago.
My Vito is automatic 113 cdi - does this have clutch hydraulics? Should I have a gear box service
Expert:  Matt replied 21 days ago.

Hello

Ok if its an auto then there's no clutch to worry about so I'd take a look at the colour of the transmission oil it should be a dark red colour if its black then its needs changing

Also check its level with the gearbox warm and just after you've moved the selector through all the positions leaving it for a few seconds in each one and then back to park.

You can top up the box through the side fill plug if required and make sure you use the correct oil for your van as the fluids are not all the same. Some manufacturers recommended a change of the type of fluid - Speak to the local dealer and parts dept - they will advise you on the updated fluid to use..

If that’s all OK then check all the electrical connections of the gearbox, remove each connector in turn and spray with contact cleaner. Check that the wiring to the gearbox is in good condition with no chafing or frayed wire

If this is OK then check the selector lever linkage / cable under the car for any broken parts

My goal is to give you the best advice that I can and I hope that I've helped today. Please remember to rate my service by selecting from the 5 stars at the top of the screen before you leave. If you need more help, use the reply box to let me know.
If you're not pleased, also let me know because rating bad does not result in a refund, there are better options. Rating now will not close this post nor prevent further replies
Thanks Matt

Matt and other Mercedes Specialists are ready to help you