How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Software Engineer
Category: Microsoft
Satisfied Customers: 38329
Experience:  Over 15 year experience resolving Microsoft Office Issues
32989067
Type Your Microsoft Question Here...
Richard is online now

I have a workbook that uses a lot of VBA in the background.

Resolved Question:

I have a workbook that uses a lot of VBA in the background. It's been working fine since last April and still is on my computer; however when I email it to my head office the controls don't work.
I understand that there has been an issue with an update from Microsoft that stopped ActiveX controls working. Their so-called "fix" doesn't fix it and I can't get any sense out of Microsoft as there doesn't appear to be an email address in the UK for their support team.
Any suggestions?
Submitted: 2 years ago.
Category: Microsoft
Expert:  Richard replied 2 years ago.
Thank you for your question, my name is ***** ***** I look forward to assisting you.
Please note, click on Reply to Expert to reply to me, a rating is only needed when we are finished.
Can I ask, are you sure the Active X controls are also installed on the home office computers? As it appears they are not which is why this would occur.
Please let me know
Customer: replied 2 years ago.

This workbook has been working perfectly since last April. I created it on my computer; I update the figures each month and email it to my head office. They have been able to read it without problem.

In December, I updated the figures as usual and emailed it over to them. They couldn't get any of the controls to work.

Expert:  Richard replied 2 years ago.
ok, can I look at the file please
- Click the following link: http://www.wikisend.com
- Upload the file to that website
- Once it is uploaded, the resulting page will display a "File ID" number.
- Please, give me that "File ID Number"
Customer: replied 2 years ago.

305504

I should point out that there have been no changes to the coding to cause this problem.

Expert:  Richard replied 2 years ago.
Thanks
What do I need to do in it to make the error occur?
Customer: replied 2 years ago.

On the first page there are four command buttons. Clicking on "Branch" should open a form; it works here but not when I email it through.

They can't get beyond the first page. They can open the tabs at the bottom, but that doesn't give them access to the forms.

Expert:  Richard replied 2 years ago.
ok, it would not work on mine either.
To get it to work, I had to add new buttons with the same code. It looks like it is getting corrupted in the transfer.
When I tried to delete the other buttons to replace it, it crashed out Excel, so the file is corrupted on my end.
Are you able to re-create the buttons on your computer and send me a copy to test please?
Customer: replied 2 years ago.

Let me try

Expert:  Richard replied 2 years ago.
Thank you
Customer: replied 2 years ago.

653664

I've put new controls for Branch and Company and deleted the original buttons and code.

It works here.

Expert:  Richard replied 2 years ago.
No, still crashing my computer
Can you do it on a different computer and send it to me please?
Customer: replied 2 years ago.

Sorry but I don't have another one available at the moment

Expert:  Richard replied 2 years ago.
ok, I renamed to XLS, removed buttons, then named back and was able to add them
You can download it here
http://wikisend.com/download/358630/Phase4Dec14.xlsm
Do they work for you?
They do now work here
Customer: replied 2 years ago.

It certainly works at this end although all of the controls are misaligned (not important as I can re-align them here); but does this resolve the issue when I send it to my head office? Why rename to xls when for macros to work the file has to be xlsm?

Expert:  Richard replied 2 years ago.
It was not working on my computer before I did this, and now works, so shows me the file was corrupted.
So it should be ok now also at head office.
I had to use XLS to get rid of the buttons as it kept crashing out the computers here (due to corruption)
Send it to head office and let me know the results please
Customer: replied 2 years ago.

I've just sent it so I'll have to wait for their reply

Expert:  Richard replied 2 years ago.
Thank you
Customer: replied 2 years ago.

They've just reported that it's working!!!!

Thank you

Great job

Still don't understand what went wrong though.

Expert:  Richard replied 2 years ago.
Perfect!
Just know it was corrupted and I resolved it
If you would like any additional information or assistance, please do not hesitate to let me know.
And if you can take a second to rate my service, that would be greatly appreciated.
Thank you
Richard and 4 other Microsoft Specialists are ready to help you