How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike_a_mechanic Your Own Question
mike_a_mechanic
mike_a_mechanic, Mitsubishi Mechanic
Category: Mitsubishi
Satisfied Customers: 5470
Experience:  17 years experience as a auto mechanic, foreign and domestic.5 years running my own repair business.
19374685
Type Your Mitsubishi Question Here...
mike_a_mechanic is online now

both traction control lights on

Customer Question

hello I've got a l200 2009. went through some mud off road and had it in 4wd. went back onto the road and put it back into 2wd. about an hour later the engine management light came on, and both traction control lights. any ideas. hope you can help. thanks glenn


 


plugged  a computer in and it came up with a manifold pressure fault

Submitted: 3 years ago.
Category: Mitsubishi
Expert:  mike_a_mechanic replied 3 years ago.
Hello, welcome. My name is Mike, I will do my very best to assist you with your question. I apologize if you have been waiting long for a response.

From what you are describing this issue is consistent with the wheel speed sensors becoming wet or clogged with mud which has affected the communication which turns on the lights. what I would suggest as a first step is to clean all 4 wheel speed sensors.