How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Mitsubishi Mechanic
Category: Mitsubishi
Satisfied Customers: 3967
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Mitsubishi Question Here...
Jake is online now

I have a 2011 Mitsubishi Outlander 2.2 diesel that is not wanting

Customer Question

I have a 2011 Mitsubishi Outlander 2.2 diesel that is not wanting to start very easily in the mornings.
I had a set of glow plugs fitted about a month ago as 2 were not lighting. I assumed this was the problem.
The car continues to be sluggish from a cold start and can sometimes turnover for 6-7 seconds, then not start. Repeating the process and sometimes heating the plugs 3 or 4 times ensures it starts after 4-5 seconds.
Then for the rest of the day it seems to be much better.
I've had the battery and alternator tested, both are fine.
Do you have any ideas what else could be wrong?
Submitted: 1 year ago.
Category: Mitsubishi
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I apologize as we have not yet been able to find a Professional to assist you. Do you wish for me to continue to search for someone to assist you or would you like for us to close your question at this time?
Thank you for your patience,
Shantal
Expert:  Jake replied 1 year ago.
i apologize for the delay in responding. There are actually a couple possibilities here, the first that comes to mind is air in the fuel lines. have you tried replacing the filter and and running the low pressure pump to purge the lines?