How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy R Your Own Question
Jeremy R
Jeremy R, Technician
Category: Motorcycle
Satisfied Customers: 2
Experience:  20+ years experience. Factory trained and certified
8380480
Type Your Motorcycle Question Here...
Jeremy R is online now

I have a mystery electrical problem with my bike. When I press

Customer Question

I have a mystery electrical problem with my bike. When I press the starter button, the starter solenoid oscillates rapidly, making a 'machine gun' sound. If I disengage the starter motor, earth it and try again, it does the same.
If I disconnect the starter lead and press the starter, it clicks on and off as per the test described in the Haynes manual.
I've changed the solenoid and the starter motor to no avail. All the relevant wiring looks ok.
It's a 2002 Yamaha XJ600 Diversion type 4BR 060. Any thoughts please?
Submitted: 2 years ago.
Category: Motorcycle
Expert:  Shantal-Mod replied 2 years ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 2 years ago.

Hi Shantal, I'd like to close the question please.

Expert:  Chris replied 2 years ago.
If you would still like assistance with this issue I have some ideas / tests for you to preform to figure this problem out?
Customer: replied 2 years ago.

Thanks for the reply but I already asked to close my question as I found out the cause was an ageing battery.

Expert:  Chris replied 2 years ago.
I will request the question be closed for you.