How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Motorcycle
Satisfied Customers: 21719
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Motorcycle Question Here...
Matt is online now

I have a 2006 smart roadster, the problem I'm having is it

Customer Question

I have a 2006 smart roadster, the problem I'm having is it cuts out whilst driving. There's no indication that it's going to happen it can happen anytime.
Both battery light and oil light illuminate and the car just cuts out.
If you then leave it for 20-20 minutes it starts again and will run ok for around 5-10 miles before happening again.
Any help or ideas would be greatly appreciated!
Submitted: 3 months ago.
Category: Motorcycle
Expert:  Nicola-mod replied 3 months ago.
Hello,
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.
Thank you!
Nicola
Customer: replied 3 months ago.
Please continur
Expert:  Nicola-mod replied 3 months ago.
Hello,
We will continue to look for a Professional to assist you.
Thank you for your patience,
Nicola
Expert:  Matt replied 3 months ago.

Hello

I'd 1st start by checking the state of the large fuses in the battery compartment and check that the battery compartment is clean and dry as they have a habit of leaking water inside which then plays havoc with corroded electrics

also check that the main battery connections are on tight and are bright and clean and do the same for the large battery connections to the engine including the earth / ground lead between engine and chassis

If this is OK then check the connections to the fuel pump, as if they are corroded or damaged then the pump could stop at any time or could not be running at full speed. Check that its relay switches in and out and the relay contacts are clean and bright – replace the relay if in any doubt and do the same for the fuse,

Related Motorcycle Questions