How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 240
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now

Nissan X-Trail 2001, Diesel, runs perfect but engine suddenly

Customer Question

Nissan X-Trail 2001, Diesel, runs perfect but engine suddenly reverts to tick over revs at odd times ie, whilst doing 70mph on a mototway or approaching a give way at 10mph. Problem rectified by turning off engine for 30 seconds (ish) and turning back on and driving away again. Research to date suggests its a common problem but a variety of solutions seem to work but need repeating every few thousand miles and range from disconnection / replacement of the tick over sensor (£100) to replacing the rather expensive fuel pump (£1000) but with no power loss, smooth running and the ignition auto reset the ECU / sensor would seem to make sense.
Regards,
Mr B
Submitted: 4 years ago.
Category: Nissan
Expert:  Mike replied 4 years ago.
Hello and Welcome to justanswer..

My name is MIKE - Im happy to help / advise you with this..

What is the mileage on the vehicle?

Do you use "normal" diesel ?

What fault codes do you have ?

Rgds, MIKE....................................
Customer: replied 4 years ago.

Hi Mike,


 


Mileage is 140k but last 23k on new engine


 


Only use normal diesel from local ASDA


 


Don`t have fault codes as thought you might know the answer to what is, judging by the internet coverage, a fairly common problem to X-Trails but with varying "solutions" most of which seem a short term fix only.


Regards,


 


Lindsey.

Expert:  Mike replied 4 years ago.
Hello again Lindsey..

I did send you a reply to the above- I have just come back to check but see its not showing... I can only assume that was some system issue, so I can only apologise for that..

As this has happened - please let me know if you still need help with this and then if so , we can carry on..

Kind Rgds, MIKE...............................
Customer: replied 4 years ago.
I sent the responses on the 1st of May and have heard nothing until today
Lindsey
Expert:  Mike replied 4 years ago.
Hello again Lindsey.

I can only apologise for what have been delays caused by system issues or whatever ..Im afraid I cant do anything about that -

Please just let me know if you do still need help with this - then we can progress if you wish -

Kind Rgds, MIKE..................................