How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, UK Qualified Car Technician
Category: Nissan
Satisfied Customers: 4639
Experience:  self employed in the motor repair buisness 19years
13210289
Type Your Nissan Question Here...
Robert is online now

I have 2005 primastar 2.5 it keeps kicking the belt off .already

Customer Question

I have 2005 primastar 2.5 it keeps kicking the belt off .already have replaced pulley and tensioner any thoughs
Submitted: 4 years ago.
Category: Nissan
Expert:  Robert replied 4 years ago.

Hi..Sorry for delay

 

I see your question is little aged...do you still require any assistance?

 

 

 

Customer: replied 4 years ago.

yes still need help

Expert:  Robert replied 4 years ago.

Hi..there thanks for your reply..

 

You say its kicked off in what way? slips/works itself off or suddenly jumps off the pulleys?

 

Does the belt have any wear/score marks or show any signs of which along the edges etc..?

 

Before this problem occurred has there been any previous work done on that side?

Customer: replied 4 years ago.


just shreds the belt.


no work done to this side


this has happened a few time and usually damages seal on ps pump aswell

Expert:  Robert replied 4 years ago.

Hi..there thanks for your reply..

 

Ok..if the belt shreds as you say then I suspect one of the pulleys that belt runs round is indeed out of alignment and causing the belt to run off,there cant be anything else that would cause unless the belts coming into contact with something,unless the alternator clutch pulley is at fault or the belt isn't tight enough - it might be worth too also following the route round and maybe see if you can see any wear marks the belts left behind and maybe give any indication as to where exactly the belt rubbing against.as you have replaced the tensioner/ps pump then you could maybe rule those out..thats only leaves really that small guide pulley/air con if fitted/alternator/or the lower crank pully..you would need to check each one in turn for any movement or free play by hand.or any signs or noticeable issues as per running out of line.maybe use a long straight edge maybe..or with the belt on observe with the engine running all the pulleys and watch to see if any are slightly wobbling especially so the lower crank pulley as I say I certainly sounds like an alignment issue..I do hope this helps further