How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 237
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now

Hello I have a 2008 navara and periodically it goes into limp

Customer Question

Hello I have a 2008 navara and periodically it goes into limp mode when pulling off at junctions and when in traffic etc. So far I have been lucky please help
Submitted: 3 years ago.
Category: Nissan
Expert:  indy-tech replied 3 years ago.
Hi .

Is your check engine light "ON" when the engine is running.

Which engine do you have Petrol or Diesel .

Rgds Greg
Customer: replied 3 years ago.
No there are no management lights on and I have a diesel. Also there are no management lights on when it is in limp mode.
Expert:  indy-tech replied 3 years ago.
Hi Lee

Please explain what is happening when you go into "Limp mode".

Rgds Greg
Customer: replied 3 years ago.
As you go to pull away as normal the the vehicle goes into like a half stall then the vehicle loses power you put you foot to the floor with no response
Expert:  indy-tech replied 3 years ago.
Hi Lee .

This looks more like a fuel starvation issue ,when was the fuel filter last changed .

Greg
Customer: replied 3 years ago.
It was serviced in November with a full comprehensive service
Expert:  indy-tech replied 3 years ago.
Hi Lee .

Was it after the service you started having this problem ??

Greg
Customer: replied 3 years ago.
Mainly yes it happened a couple of times before but put that down to driver error. If you put the clutch down turn of and restart then problem solved
Expert:  indy-tech replied 3 years ago.
Did you have the management system checked for malfunction codes

Greg
Customer: replied 3 years ago.
No I don't think so I have booked it back in at the garage for them to sort it out.

Thanks for your help

Lee
Expert:  indy-tech replied 3 years ago.
Okay thank you Lee.

Rgds Greg