How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 240
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now

instument panel not working ie speedo,temp and fuel guage also

Customer Question

instument panel not working ie speedo,temp and fuel guage also indicators not flashing
Submitted: 3 years ago.
Category: Nissan
Expert:  Shantal-Mod replied 3 years ago.

Hello,

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you,

Shantal

Expert:  Jake replied 3 years ago.

Hi there, Nissan tech Jake here.

Have you already started by verifying all the fuses are in tact and not blown?

Are you saying the actual indicators don't flash? or just that the indicator light on the gauges don't flash?

Customer: replied 3 years ago.


jake : hi there.i had already checked all the fuses were ok in the 2 boxes i knew about so i was basically stumped.


My wife needed the car functional so i had to take it to an auto electrician late this afternoon.


he replaced a fuse!all systems are now working.


the auto electrician had gone home before i collected the car so i have not been able to find out what fuse he replaced.


whether it was one i had previousley ckecked or one i did not know about


 


sorry for the inconvenience.


jim

Expert:  Jake replied 3 years ago.

Jim, I am glad it was a simple fuse!

and again I am sorry you had to wait so long to get an expert to reply. I normally am around daily but was out of town so i was not working on new questions at that time.

if you ever need help in the future just ask.