How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 229
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now

I have a Nissan terrano 2.7 touring diesel since filling

Customer Question

I have a Nissan terrano 2.7 touring diesel since filling up with diesel not from my local garage the malfunction light has come on and car is lacking power , depending on which way I turn when driving the light goes out but comes back on what can problem be

thanks barry
Submitted: 3 years ago.
Category: Nissan
Expert:  Shantal-Mod replied 3 years ago.
Hello,

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you,

Shantal
Expert:  indy-tech replied 3 years ago.
Hi .

What malfunction codes did you find when the check engine light came ON.

Rgds Greg
Customer: replied 3 years ago.


HI greg yes willing to wait for answer to my post .


 


I have had diagnostic test done which said ignition timing valve at fault .


 


But now while waiting for response to post , have found on my manual that the problem might be water in the gear box , if this is the case where do I find the water drain of plug , please . Bearing in mind that I was going through flood water to get home /work .


Car is starting up a lot better but is still lacking in power ,depending on turn light goes out and engine speed picks up .


I like to do my own mechanics as we have 4 cars in family ,but this has got me stumped .


Any help will be much appreciated ,


many thanks barry

Expert:  indy-tech replied 3 years ago.
Check the connection on the bottom of the filter .

I take it the warning light is the water in fuel warning light .

What was the malfunction code to let you know you have ignition timing valve at fault .

Rgds Greg
Customer: replied 3 years ago.


Have already checked the bottom of filter and all was ok ,


The malfunction said it was the high side in the INT ,but when I go left when driving the light goes out then car runs normal power after 3oft I then have a big power loss the malfunction light stays on , on right turns engine runs normal .


hope to hear from you barry

Expert:  indy-tech replied 3 years ago.
Hi Barry .

To know what is causing this problem you will have to be hooked up to a diagnostic scan tool to check for malfunction codes , from the malfunction codes you will then know what is causing this intermittent issue ,while each time the fault comes it will keep a code referring to the problem that the management system encounters .

So with this code you got ignition timing valve at fault do you have this PXXXX code .

Greg
Customer: replied 3 years ago.


HI Greg , They managed to put the low side back in but high side will not go back in . Have been told that I need to put another pump on with a recon being £600 plus labour , Considering car is worth about £800 . Got mechanic friend phoning FIRST DIESEL at Thornton Heath .


 


Thanks barry

Customer: replied 3 years ago.


P/# 23710-7f406 is on top don't know what this means


 


self diag results


 


F/inj Timg F/B 2


 


INJ TIMING CONT/V 0



DOES THIS HELP

Expert:  indy-tech replied 3 years ago.
Hi .

Will open this up for a fellow expert as my data bank is down and have no other data to fall back onto .

Please don't reply or this will lock you back onto me .

Rgds Greg
Customer: replied 3 years ago.


Hi Greg I know you said you were passing this on to another advisor , but through perseverance have today at long last solved what the problem was a broken wire in the loom ,where the loom goes to the back of engine it loops to come back to fuse box , can only presume when engine moved it created a short . Yellow wire . Thought this might be useful to you .


thanks barry

Expert:  indy-tech replied 3 years ago.
Hi Barry .

Yes thank you very much ,well appreciated,nice to hear you got this sorted out .

Happy motoring Barry, have a great weekend .

Kindest regards Greg