How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jake Your Own Question
Jake
Jake, Nissan Technician
Category: Nissan
Satisfied Customers: 3934
Experience:  Experienced collision repair technician, Pulaski Tech graduate and DSM hobbyist.
20440119
Type Your Nissan Question Here...
Jake is online now

My nissan micra k12 1.2 2009 automatic speedometre is

Customer Question

hi
my nissan micra k12 1.2 2009 automatic speedometre is not working, i changed clauster clock and speedometre sensor it still does not work, just in the dashboard it is showing ABS light and hand break light and both lights are on.
Submitted: 1 year ago.
Category: Nissan
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 1 year ago.
Hi
I will wait Monday morning but if you still havent found me an answer yet i would like to close my question, but do i get a refund if i did not get my answer.
Thank you
Expert:  Shantal-Mod replied 1 year ago.
Hello,
Thank you for getting back to me. We will continue to look for a Professional to assist you.
However, should you wish to close your question and reverse your charges at any time please let me know.
Thank you for your patience,
Shantal
Customer: replied 1 year ago.
I will.Thank you
Expert:  Jake replied 1 year ago.
Hey there, thanks for the question and sorry for the delay. SO if I understand you correctly. You replaced the gauge cluster, and the revolution sensor on the gearbox correct? Unfortunately, the speed signal comes from the ABS unit. The vehicle speed is determined by wheel speed sensors (4) that are located at the hubs. In order to properly correct this you are going to need to check the wheel speed sensors. Either by using a scan tool and watching the pick-up at each wheel or by using a speed sensor tool that works when you spin the wheel. The reason the ABS and brake lights are on is because a fault is detected in the ABS system, likely at one of the speed sensors themselves or with a communication line. Getting the code from the ABS unit would make it alot simpler. If you have a speed sensor code just replace the one at the wheel corresponding to the code and see if it resolves itself. If it does not then the fault is in the ABS unit itself or the CAN line to the cluster. If you need anything else or have further questions let me know. If not just be sure to leave a kind rating so the site credits me for my time. Best regards, Jake