How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask indy-tech Your Own Question
indy-tech
indy-tech, Import tech
Category: Nissan
Satisfied Customers: 7056
Experience:  Import technician
29331485
Type Your Nissan Question Here...
indy-tech is online now

I have a x trail 2.0 petrol 2003, Starts perfect when cold

Customer Question

I have a x trail 2.0 petrol 2003,
Starts perfect when cold and runs fine,
But it will not restart while hot,
If I wait 15/20 car starts and runs fin
Can anyone help with advice
Submitted: 8 months ago.
Category: Nissan
Expert:  indy-tech replied 8 months ago.

Hi, I'm Greg (Indy-Tech).
Welcome to JustAnswer. I'm reviewing your question now, and will post back with your reply ASAP.
Rgds Greg.

Expert:  indy-tech replied 8 months ago.

Hi Paul.

If the engine does not stall and only have a problem starting when hot but after 15 - 30 minutes will restart then this is normally a bad crankshaft sensor .

Very common issue that we see with many makes and models .

Also possible is a bad Ignition coil .

What happens is when the crank sensor gets hot they fail ,in most cases will not trip the check engine light .

but check for crank/cam sensor codes .

Need further assistance with this issue then please get back to me with the reply box below .
After rating there is no further cost for any other question relating this issue .
Kind regards Greg

Customer: replied 8 months ago.
There is no codes showing on the diagnostic tool
Crack sensor had already been changed because we did have a problem showing on there
Expert:  indy-tech replied 8 months ago.

Okay good thank you Paul .

Next time you have a No start situation check for spark , fuel pressure .

What i would do is when no start situation spray EZstart down the throttle body when cranking over the engine

if she starts then we have a fuel supply issue ,no start check for spark at the plugs ,no start possibler bad coil .

Check this then please get back to me .

Rgds Greg

Customer: replied 8 months ago.
it was a faulty new cam sensor in the end,thank you paul
Expert:  indy-tech replied 8 months ago.

Hi paul .just as said crank/can sensor .

Good find Paul and happy motoring .

Rgds Greg