How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Nissan
Satisfied Customers: 22160
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Nissan Question Here...
Matt is online now

I have a Nissan X-Trail and recently have noticed sudden

Customer Question

I have a Nissan X-Trail and recently have noticed sudden loss of power where I am unable to rev the engine. Switching off the engine and switching on later the problem seems sorted only to recur! Thank you for your help
Assistant: How many miles are on the car? Is it an automatic or a manual transmission?
Customer: 60000 miles and it is manual transmission
Assistant: What year is your Th!nk?
Customer: You mean how old? If so I think 11 years?. The original owner brought the car to Jersey
Assistant: Are you fixing your Th!nk yourself? What have you tried so far?
Customer: I took it to the garage and initially they could not find the problem but whilst bringing the car back to me the problem happened. I was told the problem was the accelerator pedal?
Assistant: Anything else you want the mechanic to know before I connect you?
Customer: No, thank you
Submitted: 14 days ago.
Category: Nissan
Expert:  Matt replied 14 days ago.

Hello

I'm assuming that this is the turbo diesel as this is the most common engine for these

I'd start by checking all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

and if you haven't already then also consider changing the fuel filter as if this partially blocked this will reduce pressure at the main pump
If both of these are OK then also check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If its a variable vane turbo (they’ll be an actuator on the turbo body - but not a wastegate) then check its vacuum pipework as above and check the connections to the diaphragm / solenoid valve

Also worth checking that the glow-plug relay is switching off as they can stick on and leave the glow plugs also on - on some cars this can force it into limp home

Also worth considering adding a bottle of injector cleaner into the tank as a clogged injector nozzle will reduce power and give poor combustion - the next stage on from this is to remove all the injectors and have them ultrasonically cleaned and flow checked

If the above are all OK then try checking for airleaks after the airflow meter, any air dragged in here isn't 'seen' by the ECU and so not compensated for causing rough running. As its a mechanical fault it tends not to turn on the fault light and you can sometime hear a 'hissing' noise with the engine running.

Check the hose clips for tightness and inspect the trunking for any cracks or splits and also all the vacuum system, the small bore pipes and fittings for cracks and missing parts.

The best way to locate a leak is to have the engine running and warm and then spray lighter gas around each joint in turn. If the engine rev's up you've found your leak.
Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.

Might also be worth checking the wiring and connector to the airflow meter for any signs of corrosion or damage. you can do a quick fault find if you unplug the meter and run the engine without it.
if the engine condition is the same then chances are the meter or the connection to it is faulty

its also worth cleaning the airflow meter by removing it from the car and spraying the exposed sensor wires inside the tube with a brake or switch cleaner - ensure that the cleaner is one of the old fashioned, non Eco type that does not leave a residue

On no acc**t touch the sensor wires with anything physical as they are extremely fragile

Expert:  Matt replied 8 days ago.

Hi
do you still need help?
Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you