How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mark Your Own Question
Mark
Mark, Peugeot Certified Technician
Category: Peugeot
Satisfied Customers: 1504
Experience:  Fully qualified technician and MOT tester.
69494627
Type Your Peugeot Question Here...
Mark is online now

I have a 2004 partner 2.0 hdi. The alternator is not charging

Customer Question

I have a 2004 partner 2.0 hdi. The alternator is not charging the battery. I've put a new alternator on and still the same fault. I only have a low voltage coming down the exciter wire between 5 & 8 volts. If I put a 12v feed to this for just a second, it gets the alternator going and everything works fine.
The charge light though works correctly. It is lit when you turn the ignition on and goes out when you start the engine. Do they have any sort of charge relay etc?
Thanks
John
Submitted: 3 years ago.
Category: Peugeot
Expert:  Mark replied 3 years ago.

Mark :

Hello, my name is Mark and I will try help you with this.

Mark :

I suspect the fault is due to either a corroded or partially broken exciter wire connection.

Mark :

Corroded wire connection will pass voltage but not current which is probably why you are getting a low voltage reading but there is not enough current passing through the alternator to allow it to start charging.

Mark :

When you give it an independent 12v feed it works so this suggests a fault with the exciter wire.

Mark :

Check the wire at both ends if possible for signs of internal breakage or copper corrosion, (turning green)

Mark :

(or black)

JACUSTOMER-5eahw8em- :

Do you know where the other end of the exciter wire goes too. I've checked the alternator end and all seems ok but when I try and trace it back it goes into part of the loom and i'm having trouble tracing it?

Related Peugeot Questions