How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Curtis B. Your Own Question
Curtis B.
Curtis B., Technician
Category: Small Engine
Satisfied Customers: 28322
Experience:  Service manager and technician for all brands of engines with 40 + years of experience.
30244710
Type Your Small Engine Question Here...
Curtis B. is online now

I have a mountfield ride on 20/40 when i pull the start

Customer Question

I have a mountfield ride on 20/40 when i pull the start switch for the blades the charge light comes on after a few minutes it stops
Submitted: 10 months ago.
Category: Small Engine
Expert:  Curtis B. replied 10 months ago.

Engine model number? The charging system is not keeping up with the voltage demand from the electric clutch. Battery can be weak or too small, or the stator/alternator and voltage regulator or diodes are not letting the charging system get the DC volts to the battery for charging. Do you have a voltmeter to check battery voltage before starting and with engine running ?

Customer: replied 10 months ago.
What should the voltage be
Expert:  Curtis B. replied 10 months ago.

Voltage can not drop below 12 volts, or the electric blade clutch will drop out. Checking battery voltage before start, should be 12.5 volts or above, and with engine running at speed, the voltage should increase at least one volt, to above 13.5 if the stator/alternator is working.

Customer: replied 10 months ago.
What should the voltage be when the blades are running please
Expert:  Curtis B. replied 10 months ago.

minimum of 12 volts Dc!

Curtis B. and other Small Engine Specialists are ready to help you
Customer: replied 10 months ago.
Thank you I'll check the voltage and I'll come back to you
Expert:  Curtis B. replied 10 months ago.

OK> Thanks.

Expert:  Curtis B. replied 10 months ago.

Payment failure. Do you need call? Did you ever give me the engine model number?

Customer: replied 10 months ago.
I have got a problem with the voltage when I check it was ok but then the charger light started flashing and the engine cuts out
Expert:  Curtis B. replied 10 months ago.

Do you have good battery? How old and has it been load tested? Seems like charging system may be dropping out, and this can be voltage regulator, but with out mode number of the engine, don't know what you have for a voltage regulator.

Customer: replied 10 months ago.
It's a new battery 22 amp when I check it it was reading 16volt
Expert:  Curtis B. replied 10 months ago.

So not a battery problem, so it has to be the charging side.

Related Small Engine Questions