How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Toyota
Satisfied Customers: 21720
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Toyota Question Here...
Matt is online now

I have a toyota dyna 03 plate. when I come to slow down at

Customer Question

I have a toyota dyna 03 plate. when I come to slow down at a junction the revs drop and the engine management light comes on (limp mode) It only tends to do this for the first 3-4 miles in the morning and then it clears for the remander of the day - some times I can go for days without the problem happening then I it starts again, I have discovered that turning the ignition key to start the truck although it is already running makes the starter whine but it resets the engine and i'm off and running again.
Could anyone help me diagnose this problem?
Submitted: 3 years ago.
Category: Toyota
Expert:  Matt replied 3 years ago.

Hello

1st consider changing the fuel filter as if this partially blocked this will reduce pressure at the main pump

If OK then also check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If its a variable vane turbo (they’ll be an actuator on the turbo body - but not a wastegate) then check its vacuum pipework as above and check the connections to the diaphragm / solenoid valve

Also worth checking that the glow-plug relay is switching off as they can stick on and leave the glow plugs also on - on some cars this can force it into limp home

Also worth considering a bottle of injector cleaner into the tank as a clogged injector nozzle will reduce power and give poor combustion - the next stage on from this is to remove all the injectors and have them ultrasonically cleaned and flow checked

Also check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

If the above are all OK then try checking for airleaks after the airflow meter, any air dragged in here isn't 'seen' by the ECU and so not compensated for and leans the engine out causing rough running. As its a mechanical fault it tends not to turn on the fault light and you can sometime hear a 'hissing' noise with the engine running.

Check the hose clips for tightness and inspect the trunking for any cracks or splits and also all the vacuum system, the small bore pipes and fittings for cracks and missing parts.

The best way to locate a leak is to have the engine running and warm and then spray lighter gas around each joint in turn. If the engine rev's up you've found your leak.

Work your way through each possible joint one at a time and you should find it. I use a slightly flattened piece of brake pipe and some rubber hose from the can of lighter gas to provide a spraying 'wand' and allow a direct blast of gas into each area, especially those difficult to reach with large implements.

Related Toyota Questions