How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Toyota
Satisfied Customers: 21990
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Toyota Question Here...
Matt is online now

I have a toyota praevia diesel 2.4. The engine will suddenly

Resolved Question:

I have a toyota praevia diesel 2.4. The engine will suddenly cut out, losing all power and the yellow engine sign is displayed. The engine will restart after turning ignition off and on but the warning light persists for a day or two. The problem seems to be related to longer journies especially when accelerating or progressing uphill but is not restricted to that. It can be dangerous especially when trying to overtake a vehicle./ Someone suggested it may be due to exhaust sensors. Any ideas?
Submitted: 3 years ago.
Category: Toyota
Expert:  Matt replied 3 years ago.

On any car if you get a check engine light or other fault light this typically means one or more of the sensors has failed or has a faulty connection.

The fault can be something quite simple and nothing that’s going to stop the car to something quite major that will reduce engine power and possibly stop the engine

The ECU senses this and may put the car into 'limp home' mode which typically limits the revs and the amount of power available. Usually the car is safe to drive for a short distance as the mode is intended is intended to get you home without incurring any engine damage

The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious.

You can do a very rough and ready check yourself by unplugging sensors one at a time and seeing if any of them change the driving condition which would indicate the most recently unplugged sensor is the faulty one. This method is not foolproof though and reading a fault code off is the better method.


however from your description I think it could be a wiring issue as things tend to expand when hot and its possible a poor or partial electrical connection is being pushed apart on one of the major sensors so check the connection plug and wiring to the following;
Airflow meter
Crank position sensor
Cam position sensor
O2 sensor
Throttle pedal position sensor


Also worth checking the connections to the fuel pump for the same reason - unplug each in turn and give them a good squirt of switch / contact cleaner - Not WD40

and also unplug and inspect the main power relays and fuses for signs of overheating or corroded terminals - so the ones for the ECU and the fuel pump

And also unplug the wiring loom connections in the engine bay one at time and inspect for corroded or recessed pins.
Matt and other Toyota Specialists are ready to help you