How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Toyota
Satisfied Customers: 22168
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Toyota Question Here...
Matt is online now

i have a toyota lucida ,ive just fitted brand new head,head

Customer Question

Hi i have a toyota lucida ,ive just fitted brand new head,head gasket,waterpump,radiator ,now the promblem is i can hear water running through the heater matrix on acceleration...besides this car runs fine ,no overheating and interior heater works as it should ,ive tried bleeding and flushing system and its fine for 20 mins and then the sound of gushing water comes back......should i probably change matrix ?
Submitted: 2 years ago.
Category: Toyota
Expert:  Shantal-Mod replied 2 years ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Matt replied 2 years ago.
Hello

the moving water sounds may not be coolant moving about, its well worth checking the condition of the scuttle panel drain pipes

if you look under the car there's a couple of rubber pipes either side of the transmisson tunnel - try using a thin metal rod to remove and clogs
Customer: replied 2 years ago.

toyota lucidas dont have a scuttle panel to drain off water ,furthermore the sound completely goes when heater switch is positioned to cold

Expert:  Matt replied 2 years ago.
Hello

thanks for the extra information

in that case I'd agree that air must be being drawn into the system

Check all the rubber hoses for any signs of leaking and tighten up clips as required and before replacing the mattrix I'd try a bottle of this

http://www.kalimex.co.uk/section.html?secpath=01.04.&pgid=17

as its very good at sealing small leaks without clogging the galleries up
Customer: replied 2 years ago.

thanx will try some first thing in morning ,will let u know in evening how it goes.

Expert:  Matt replied 2 years ago.
understood
Expert:  Matt replied 2 years ago.
hi
do you still need help with this?
Customer: replied 2 years ago.

tried k.seal n now after a long drive i loose heating when car is left idling which it didnt do b4.

Expert:  Matt replied 2 years ago.
Hello

OK are you still losign coolant?
Customer: replied 2 years ago.

no like i said new head,headgasket,radiator,water pump,and expantion tank bottle and coolant never moves and temp gauge sits where it should even when i drive it at 90 mph on motorway the car doesnt overheat at and after that drive i can open water bottle immediately and no bubbles in water either.

Expert:  Matt replied 2 years ago.
Hello

OK in that case the matrix must be drawing in air and have 1 or 2 tiny holes

Sorry to say it sounds like the matrix will have to be replaced