How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt
Matt, Mechanical Engineer
Category: Toyota
Satisfied Customers: 21860
Experience:  BEng hons Mech engineering, in auto industry 22 years
12772297
Type Your Toyota Question Here...
Matt is online now

I hav a 05 avensis d4d and when im driving it at a low

Customer Question

Hi I hav a 05 avensis d4d and when im driving it at a low speed especially and put my foot on the brake the abs activates I can feel the vibration and hear the noise of the abs cud u please tell me what's the cause of this
Submitted: 1 year ago.
Category: Toyota
Customer: replied 1 year ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Expert:  Matt replied 1 year ago.
Hello If the ABS light is staying on then this would indicate a fault with the system which shouldn't effect the regular braking performance so the car is still safe to drive. The quickest route to repair is to have the car plugged into a diagnostic machine which will read off the fault code stored in the ECU (providing the light is still on at this point) and indicate which sensor has failed or whether the fault is more serious. However with ABS systems 99% of the time its a problem with one of the wheel speed sensors and I'd first check the connections at all four corners first for any signs of corrosion or chafed wiring.The sensor is located in the wheel hub so you'll have to remove each wheel in turn to inspect them all.Also check that the toothed wheel that the sensor points to is clean and free of any debris.you can check each sensor's function by plugging the two output wires into an AC voltmeter and spinning the wheel quite quickly, you should get a voltage signal that increases with rev's. Its possible that the fault is only a bad connection to one of the wheel sensors.This may be remedied by removing each wheel in turn and unplugging each sensor and cleaning the contacts with a squirt of electrical contact cleaner. Then refitting.
Expert:  Matt replied 1 year ago.
Hido you still need help?Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you