How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, Other
Category: Vauxhall
Satisfied Customers: 39198
Experience:  Tech Expert
9261905
Type Your Vauxhall Question Here...
Mike is online now

hi.there if have a corsa 1.4 se 2010 model ,the car does not

Customer Question

hi.there if have a corsa 1.4 se 2010 model ,the car does not seem to be circulating the coolant back to the header tank [small pipe at top of header tank]the car has only done 29,000 miles ,could it be the electronic controlled thermostat or the water pump .the car had to go into the main dealers the other day to have some kind of housing/pipe change as that had cracked causing coolant leakage ,this is just above the gearbox side of engine. many thanks lee.
Submitted: 4 years ago.
Category: Vauxhall
Expert:  Mike replied 4 years ago.
Hello Lee and Welcome to justanswer..

Yes, this very well could be as you say - it does need checking ...and I would say that as you have had the dealers working on - you need to contact them, tell them what's happening and take it back... It could just be that they have not bled it properly after what they have been doing.... So in any event, that's the first move on this -

I dont really suspect that you have a blockage - not at that mileage - but it can happen. The small pipe that you refer to needs checking to see if its clear - and too - the pipe that it connects to on the expansion tank - blow them through to see if they are clear - or not and deal with then as find...

If the car is not overheating - I really wouldn't expect a water pump issue - if a car has a broken water pump it doesn't take five mins use for it to overheat...and boil up in the expansion tank quickly - If its not doing that - I would suspect as above- ( check for blockages ).. and then the thermostat / bleeding issue as mentioned..

All that needs to be checked first -- It is possible the engine has developed an internal or head gasket issue - but they would need to check fan / cooling system operations first - and then they will check for that as needed....

Let me know if you need anything more on this at all -

Meantime -- Please click on the OK rating to Excellent ratings service for me now, Thank you for that... and you can get back to me anytime if you need / wish..

Best Rgds, MIKE.


Please note, you are rating the content of my "answer" - my help to you - not the "system" which can experience delays etc... which are not under my personal control -or delays caused by "time -off" which we all have on occasion - Thank you.