How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Nathan B Your Own Question
Nathan B
Nathan B, Nvq3 motor mechanic
Category: Vauxhall
Satisfied Customers: 3
Experience:  Over 20 years experience including running my own garage working on a wide range of vehicles.
27720961
Type Your Vauxhall Question Here...
Nathan B is online now

Hello 10 days ago i bought a very clean 53 plate (04) Astra

Customer Question

Hello
10 days ago i bought a very clean 53 plate (04) Astra van, 17 dti Isuzu engine. It ran sweet & pulled well 127,000 documented miles. A couple of times it took two attempts to get it started but it always fired & ran smoothly. Drove to work last night no problem, returned to it 7 hours later (when temp was only 1 degree) & it cranked but wouldn't fire. I thought Glo plugs, as did the RAC guy who got me going with Easy start. Drove 40 miles home with no problem, 2hours later it started second attempt & ran fine. I replaced the glo plugs when the engine had cooled just enough to work on (hour & a half or so) Turned it over & nothing, not even an attempt to fire. Have checked all under bonnet fuses & any connections i can see. Engine management light goes out when its cranked over. Any input on this would be greatly appreciated. Thanks.
Submitted: 3 years ago.
Category: Vauxhall