How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Robert Your Own Question
Robert
Robert, Vauxhall Technician
Category: Vauxhall
Satisfied Customers: 4568
Experience:  Fully qualified 19+yrs exp/self employed technician in the UK
13210289
Type Your Vauxhall Question Here...
Robert is online now

Hi, re. the yellow oil light you mentioned that there may

Resolved Question:

Hi,
re. the yellow oil light you mentioned that there may be an oil pressure issue somewhere. It comes on intermittantly. How can i trouble shoot this. Is the charge hose the one I just re attached. How much is an excessive amount of oil?

thanks
Submitted: 3 years ago.
Category: Vauxhall
Expert:  Robert replied 3 years ago.

Hi.there..

 

Firstly you need to check the connections to that sensor - i have an image below for the 1.3cdti engine - There is also a oil level sensor at the sump so check that too...oil pressure can only be checked using a suitable gauge in place that pressure switch,if you dont have a guage then any good well equipend garage should be able to that for you - i have the readings below to check - one thing you could try is full oil/oil filter change and see if that helps..there maybe many reasons provided the level is correct when cold engine..its always best to consider having the pressure checked..As far as the charge hose goes you shouldnt have excess oil within those pipes..you would expect to have film of oil in there from the turbo unit a fine mist within the hoses as all turbo charged systems will have diesels more so..I do hope this helps..if you need to ask anything else or include anything further then just continue before you rate

 

 

Oil pressure (Engine at operating temperature)1.0 /(NNN) NNN-NNNN/td>(bar/rpm)
Oil pressure (Engine at operating temperature)3.0-3.5 / 4000(bar/rpm)

 



Customer: replied 3 years ago.

That is helpful yes.


I should add that i recently had a new/second hand engine fitted. Someone suggested that I may need to change over the old sump. Would this help or maybe it is just a sensor issus as you say

Expert:  Robert replied 3 years ago.

Hi..there..

 

If you second hand engine fitted..it would be best to double check those sensors/connections etc..aswell as the oil pressure check anyway just to rule it out..this ensures there is no mechanical problem with the engine..I wouldnt recommend a engine flush additive as they can often wash away vital lubrication that doesnt get drained off during an oil change..always best to use a much cheaper oil as flush and drain that off before adding better oil.if its intermittent as you say it does sound like a sensor fault/connection issue

Robert and other Vauxhall Specialists are ready to help you
Customer: replied 3 years ago.

Hi


thanks for that. I'll check that and may be back to you


 


thanks

Related Vauxhall Questions