How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike
Mike, Other
Category: Vauxhall
Satisfied Customers: 39198
Experience:  Tech Expert
9261905
Type Your Vauxhall Question Here...
Mike is online now

My58 plate 1-0 litre petrol Corsa is running poor, Ive taken

Customer Question

My58 plate 1-0 litre petrol Corsa is running poor, Ive taken the plugs out and they are very sooty, I put new ones in it ran for a day then started again, the engine management light has come on, I serviced it 3 months ago, it has run fine till now.
Submitted: 3 years ago.
Category: Vauxhall
Expert:  Mike replied 3 years ago.
Hello and Welcome -

My name is MIKE - Im happy to help you ...

Before we progress - please tell me the mileage of your Corsa..

Also - please tell me the MAKE and Numbers of the plugs you have removed AND also, the ones you have fitted... This is important please..

Too - I note you say you have the engine management light on... Please describe the light for the me ( There are two types on these )...
And have you therefore had any plug in diagnostics done / any fault codes - as the light is on?

What sort of "use" / driving does your Corsa get .. ie - motorway / town mailny etc ?

Finally - please give me the cars Full reg number -

Once I receive your reply , I will get back to you asap..

Kind Rgds, MIKE..............................
Customer: replied 3 years ago.

Hello Mike


The reg is PE58UTJ, the plugs are NGK(R) ZFR5F the ones I took out and put in, the mileage is 30733, and the engine light is orange/yellow the one without a spanner in it, it is used mainly around town and only when I get in it does it get a motorway run, it is not showing any fault codes as I can see, and it has not been on a diagnostics machine, this only happened Sunday15/6/14

Expert:  Mike replied 3 years ago.
Hello there Ernie -

Thank you for your reply - my apologies that I could only just get back to you at this point..

Ok - with the lamp on that you have -this is indicating that there is a fault with the Emissions control system -

Now - this can be one or more of many things - from a simple air leak - to a faulty connection...to a faulty air mass meter to a faulty Egr valve / lambda sensor -catalytic converter - and the list goes on.

Certainly your symptoms do all add up - to it being that type of a fault... I asked about the plugs because some models needed a hotter heat range plug fitted to thwart some issues - but yours is not that type going off the reg...

So- we cannot guess what the fault is -whats causing your issues.. What you need to do if you haven't already , is make a close inspection of all the pipe work - vacuum pipes etc - check for any poor fitting pipes/ splits etc - anything like that will cause this - and also too, check the various wiring / connections to the various sensors on the engine... Clean if needed with a contact spray cleaner and re try - This should always be done first - as often such as above can cause such issues.

If you cure it that way - great. The light will go off and all will be well.

If not - then you will have to have a plug in "diagnostic test" - Actually this is a simple "Fault code read" - Most all small type garages can do this for you so will be quicker - and cheaper than dealers.

What you have there is the light on as above - so the computer on the car will have logged a fault code/s for the fault - Having the code read done quickly points to the caus e of your troubles. While some owners baulk at having to have this done, it is the proper way forward - and of course saves a considerable amount of time - and money in replacing parts hoping to hit on the fault - you just cannot logically do that these days.

So check it as I have outlined above - pay particular attention to the pipes - and un metered air going through to the engine will upset the sensors on the emissions side... but if you don't find the cause - have the fault code read done and that will get to the bottom of this for you ---

If there is anything more you need or would like to discuss - by all means get back to me and we can carry on...

.>> Meantime ...........Please do click on the "OK/ Excellent ratings" for me as that's how Im credited for helping you - Thank you in advance for that...

You can and are most welcome to get back to me anytime you might need - clicking the OK ratings does not close you out at all..


Kind Rgds Ernie - MIKE.


Related Vauxhall Questions