How JustAnswer Works:

  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.

Ask Mike Your Own Question

Mike
Mike, Other
Category: Vauxhall
Satisfied Customers: 39198
Experience:  Tech Expert
9261905
Type Your Vauxhall Question Here...
Mike is online now

Hellobi have Vauxhall Astra VXRacing Z20LEH MK5 2009, 2.0 ltr

Resolved Question:

Hellobi have Vauxhall Astra VXRacing Z20LEH MK5 2009, 2.0 ltr Turbo Petrol, since i booked my car in vauxhall for cambelt n water pump changed so my car is not pulling as vxr does, it feels like i am running normal astra without turbo and between 3000rpm - 4000rpm its loosing power and boost, feels like turbo is not kicking in and engine giving its own power its very loud when it touches 3500rpm, some one told me that maybe a mechanic changed the actuator coz as far as i know the person who carried out the work on my car he had blue vxr it could be this or some thing else can u plz help thank you
Submitted: 1 year ago.
Category: Vauxhall
Expert:  Shantal-Mod replied 1 year ago.
Hello,
I'm Shantal and I'm a moderator for this topic.
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I was checking to see if you had already found your answer or if you still need assistance from one of the Professionals.
Please let me know if you wish to continue waiting or if you would like for us to close your question?
Thank you,
Shantal
Customer: replied 1 year ago.
i have not received any answer for the questions i have asked
Expert:  Mike replied 1 year ago.
Hello and Welcome -
My name is ***** ***** Im happy to help you ..
Im sorry to see you have had a wait - this is very unusual but can happen...
Please let me know if you do still need help with this - if so, we can carry on..
If you do - please let me know what you have done meantime - where you are up to.. Also - any results from plug in diagnostic tests..
Best Rgds, MIKE..........................
Expert:  Mike replied 1 year ago.
Hello again -
Im just checking in with you as you didn't get back to me after my info request -
Please let me know if you do still need help -
Rgds, MIKE.....................
Customer: replied 1 year ago.
what i should say coz i already said each and everything but you are still not understanding the problem, didn't gave me the answer which i was looking for, i lives near heathrow airport, i changed the plugs there is nothing wrong with them, i changed the battery genuine vauxhall, i changed lambda sensor both before cat and after cat, i changed the boost pressure sensor, i changed wastegate sensor, i changed the exhaust, my car was absolutely fine and was pulling like a train but since i gave it to vauxhall to change the cambelt and waterpump from the same day i am having problems, car is not fast enough, it built to run like a jet but now its not any more, exhaust sound used to be very loud, but now its very quite, when i am in racing mode so after 3500 rpms car looses mid range boost and torque its not pulling hard its feels like my car is running without turbo, these are the problems i am having in my car now tell me what you can do thank you
Customer: replied 1 year ago.
Relist: Other.
what i should say coz i already said each and everything but you are still not understanding the problem, didn't gave me the answer which i was looking for, i lives near heathrow airport, i changed the plugs there is nothing wrong with them, i changed the battery genuine vauxhall, i changed lambda sensor both before cat and after cat, i changed the boost pressure sensor, i changed wastegate sensor, i changed the exhaust, my car was absolutely fine and was pulling like a train but since i gave it to vauxhall to change the cambelt and waterpump from the same day i am having problems, car is not fast enough, it built to run like a jet but now its not any more, exhaust sound used to be very loud, but now its very quite, when i am in racing mode so after 3500 rpms car looses mid range boost and torque its not pulling hard its feels like my car is running without turbo, these are the problems i am having in my car now tell me what you can do thank y
Expert:  Mike replied 1 year ago.
Hello again..
This is MIKE..who responded to you with an INFO REQUEST... I was asking 1, if you still needed help and 2 - if so, what you have done to try and correct your issues - inc any diagnostic tests...
--- You say above.. in part -- ... ".... you are still not understanding the problem, didn't gave me the answer which i was looking for,...."
--- Again - I have not given you ANY answer as yet... I sent you an INFO REQUEST only as above.. You did not reply to me with the answer to my Info request - instead you wrote all that you did.. and then you put your question as a RELIST .. and - listed a new, duplicate question.
.... What you need to do is simply tell me if you do still need help... THEN - as I said.. We can carry on.. and I can ANSWER you ..
It appears you do indeed still need help - and I am happy to help -
--Therefore, please just reply to THIS here... and confirm if you still want help - my help.. THEN, if so, we can carry on as I said before..
Rgds, MIKE.......................
( Please Do NOT Re list your question or post a new , duplicate question - this causes delays for you.. Just reply to me here - on this question )
Customer: replied 1 year ago.
yes i do need help thank you, ***** ***** been diagnosed and there were 4 codes so the garage told me you have to change these parts i did it but still the problem is there, car going in LIMP MODE if i am pulling 3500 rpm
Expert:  Mike replied 1 year ago.
Hello again -
Thank you for your reply -and further info.
Ok - so what I need to know now is what exactly were the parts you replaced..and - if you have a record of them, the fault codes that were obtained also..
Also - you say the car is still going into Limp Mode... that will mean the engine light is coming on still - and also, there will be yet more fault codes - Have you had it re checked then again now - to see what the latest codes are ?? If so , what are they -?
Rgds, MIKE..................
Customer: replied 1 year ago.
they garage diagnosed it and deleted all codes so i thought thats it then when i was racing again the service light came up and car went in limp mode i did the pedal test there are no codes at all and the service light went off next morning but when i drove it again it feels like car is still in limp mode but not showing service light, i can't remember all codes but P0115 i only remember, there were 4 codes in total
Expert:  Mike replied 1 year ago.
Hi again..
Thank you for your further info..
It would be handy if we could have got the codes but never mind - if the light comes on - and stays on - you would be best to get it re read.. ( the pedal test is not all that to be honest )..
The code you have recalled is for temp / coolant system issues...maybe relevant , Ill come back to this.....
All along though you have complained that the car seems to be in limp mode - ie, lack of power.. and this since the timing belt was done.
Regardless of codes then, there is every possibility that the belt hasn't been fitted correctly and / or, its jumped a tooth. This will put the valve timing out.. not enough to cause damage to the engine maybe - but certainly enough to reduce power output - as you describe. It will feel as though its "holding back"... a general lack of power -- almost like its in Limp Mode yes.
Given all that you have described -and the lack of fault codes ( and a jumped belt only a tooth or two will not always put the light on permanently ).. my suggestion would be to re contact the garage that did the belt job for you.. tell them what you are experiencing - and tell them that its only since they did the timing belt job -and tell them that you have been told the belt / valve timing needs double checking as that will indeed cause what you have there.
-- In any case - with any car- if its experiencing a general holding back / lack of power etc after a timing belt job - its always the next step... to have the belt job / timing re checked.
Its a pain... they wont want to do it... but they have to to make progress to fixing this for you.
With the absence of any other information - and certainly with what you have outlined to me, checking of the belt / valve timing has to be the next job to get to the bottom of this for you.
General things like fuel filter - air filter etc can and should also be checked - inc fuel pressure etc.. all these things can cause what you describe.. but - if they are all ok - the belt timing has to be checked now.
( Going back to the fault code you mentioned - I said Id come back to this.. If its generating that code, it can very well be that the belt is out of time.. it can cause cooling system issues - overheating or under heating..due to over advanced timing - or retarded timing so again - you can see that that code may have a relevant bearing here..)
Let me know how you go..and / or let me know if you need anything further on this..
~~~~ MEANTIME - Please do click on the "Exc / Ok rating" for me at this time.. "Thank you" in advance for that .
.. Note that you can get back to me anytime at all after doing the rating - it doesn't close you out --
Best Rgds, MIKE.
Mike, Other
Category: Vauxhall
Satisfied Customers: 39198
Experience: Tech Expert
Mike and other Vauxhall Specialists are ready to help you

What Customers are Saying:

 
 
 
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
< Previous | Next >
  • 9 dollars, 2 hours of my time, and I drove away. Your diagnosis was right on the mark. Thank you so much. Phil
  • Lurch. Thank you very much. I had real doubts about this website but your promptness of response, quick followup and to the point answer with picture was incredible. Charles
  • As a single woman, I really appreciate an excellent and affordable opinion.
    Thank you Geordie, I will not hesitate to contact justanswer in the future!
    Sue
  • Another great insight to what may be the problem. I will have my mechanic take a look at it tomorrow. Thanks again, Frank...you do indeed know your stuff. Jim
  • I would (and have) recommend your site to others I was quite satisfied with the quality of the information received, the professional with whom I interacted, and the quick response time. Thanks, and be sure that I'll be back whenever I need a question answered in a hurry. Stephanie P
  • Wonderful service, prompt, efficient, and accurate. Couldn't have asked for more. I cannot thank you enough for your help. Mary C.
  • This expert is wonderful. They truly know what they are talking about, and they actually care about you. They really helped put my nerves at ease. Thank you so much!!!! Alex
 
 
 

Meet The Experts:

 
 
 
  • Robert

    Robert

    Vauxhall Technician

    Satisfied Customers:

    155
    Fully qualified 19+yrs exp/self employed technician in the UK
< Previous | Next >
  • http://ww2.justanswer.co.uk/uploads/FO/fordtwo/2014-12-19_163422_arrepair.64x64.jpg Robert's Avatar

    Robert

    Vauxhall Technician

    Satisfied Customers:

    155
    Fully qualified 19+yrs exp/self employed technician in the UK
  • http://ww2.justanswer.co.uk/uploads/IN/indytech/2013-8-8_102717_SantoDomingo146598x6402.64x64.jpg Greg's Avatar

    Greg

    Technician

    Satisfied Customers:

    1095
    Automotive diagnostic tech
  • http://ww2.justanswer.co.uk/uploads/35/350matt/2012-6-7_182356_matsavatr.64x64.jpg Matt's Avatar

    Matt

    Mechanical Engineer

    Satisfied Customers:

    4636
    BEng hons Mech engineering, in auto industry 22 years
  • http://ww2.justanswer.co.uk/uploads/TE/techmachine/0601821347169_717372168_8940977_39623330_o.64x64.jpg Ross's Avatar

    Ross

    Diagnostic and repair technician

    Satisfied Customers:

    467
    Licensed diagnostic and repair technician
  • http://ww2.justanswer.co.uk/uploads/RO/RobMechanic/068.64x64.JPG Rob's Avatar

    Rob

    ASE Certified Technician

    Satisfied Customers:

    82
    30 years trade experience
  • http://ww2.justanswer.co.uk/uploads/UK/ukiaibal/2012-11-9_205920_SAM0109.64x64.JPG uk_iaibal's Avatar

    uk_iaibal

    UK Car Mechanic

    Satisfied Customers:

    1
    Verified Car Mechanic.