How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Nathan B Your Own Question
Nathan B
Nathan B, Nvq3 motor mechanic
Category: Vauxhall
Satisfied Customers: 146
Experience:  Over 20 years experience including running my own garage working on a wide range of vehicles.
27720961
Type Your Vauxhall Question Here...
Nathan B is online now

I have a problem with my insignia ctdi 2009, keep showing service

Customer Question

i have a problem with my insignia ctdi 2009, keep showing service vehicle soon which has been done and car loose power and stops wait a while start the engine runs as normal again
Submitted: 1 year ago.
Category: Vauxhall
Expert:  Nathan B replied 1 year ago.
Hi MichaelWelcome to ja.comI hope I can be of help to you today, but first I need to ask you some questions so my answer is better sourced.Firstly, you say you keep clearing the service light. Is it just the service light you are clearing or are you doing the oil life as well?Secondly, when the car loses power are there any other lights that come on on the dash like the engine light?Are there any other messages that come on in the dash info screen?I look forward to your repliesThank you in advanceNathan
Customer: replied 1 year ago.
Oil life as well
When loose power no other lights only service vehicle soon.
Expert:  Nathan B replied 1 year ago.
Hi MichaelThank you for your speedy reply. Sorry about all these questions. I hope you can appreciate that we may have to do a bit of this first so I can better answer you to make sure you are completely satisfied. I just have a few more questions though. Did the oil life go up to 100% in the display? Also wham you tell me it is losing power is it the electrical power that it loses or is it that it goes into limp mode where you cannot go over approx 2000rpm?I look forward to your replyNathan
Customer: replied 1 year ago.
Oil life 100% not electrical cause lights are on goes on into to limp mode cut off the engine.
Expert:  Nathan B replied 1 year ago.
Hi again. Ok. The fact it is going into limp mode means that the ecu is getting a signal from one of the sensors on the engine to say that there is a fault. This could be one of many faults as there are numerous sensors nowadays on cars. What you are going to have to do I'm afraid is get the car put on a diagnostic computer to get the fault codes that are stored on the ecu read so that you can get to the bottom of which sensor is playing up. I do know from experience that the egr valves give a lot of trouble and this may be the case here, but I would need the fault codes first to determine this. You don't need to go to a main dealer to get this done as most garages nowadays have diagnostic equipment that can do this. That is unless you have access to one yourself. Once you have the fault codes you can post them on here and I will help you further if necessary. This will now be asking you to rate my answer, but you don't have to rate until you are completely satisfied with my answer as I strive to give the best possible answer with the information I have to work with. I hope I have been of help to you and please remember to rate my answer when you are satisfied. Thanks in advanceNathan
Expert:  Nathan B replied 1 year ago.
Hi Michael. I was just chatting to a colleague of mine and a very common fault with the insignia which would put the light on and put it into limp mode is a split in the rubber turbo intake pipe quite low down. The fault codes that would come up with this are P0299 (intake pressure to low ) and possibly P2282 (incorrect intake pressure).I hope this has helped you some more. Please remember to rate my answer when you are satisfied.Thanks in advanceNathan