How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask hsroy79 Your Own Question
hsroy79
hsroy79, Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 2832
Experience:  Camera and Video TechnicianBachelor's Degree
34714361
Type Your Camera and Video Question Here...
hsroy79 is online now

Have Panasonic Lumix camera DMC-TZ20, about 2 1/2 years old. Original

Resolved Question:

Have Panasonic Lumix camera DMC-TZ20, about 2 1/2 years old.
Original battery started not to retain charge for more than a few minutes camera operation a few weeks ago so ordered new battery from Amazon. Official Panasonic Lumix DMW-BCG10E.
But new battery shows same problem as old one...seems to charge up (green light goes out) but only gives a few minutes of camera operation before camera stops functioning.
Battery charger is original one that came with camera...DE-A66A.

Is it more likely that camera or charger or batteries are at fault? Anything I can do to fault find? If not, I can take all to nearest Panasonic store in Bournemouth, but will they be able to diagnose in store, or will they have to send away? Holiday coming up so don't want to do that!
Appreciate any guidance.
Submitted: 3 years ago.
Category: Camera and Video
Expert:  hsroy79 replied 3 years ago.
Hi I am Himadri..

1.Remove the battery and memory card from the camera.
2. Let the camera sit with the battery and memory card removed
for approximately 20 minutes.
3. Clean your battery contacts with a clean cloth.
4. Re install the battery and power on the camera and let me know the result..
Customer: replied 3 years ago.

ok, done that.


camera operates, but then it always did for a short time.


so presumably have to wait a while and report back?

Expert:  hsroy79 replied 3 years ago.
Unfortunately what you have described indicates that your problem seems to be with the main circuit board it is not getting the power supply properly that,s why you are facing this type of problem.

Is your camera under warranty ?
Customer: replied 3 years ago.

no

Expert:  hsroy79 replied 3 years ago.
If it is not under warranty then please don't send your camera to service center because the repairing cost is too high almost a new camera price....If you are buy a new camera then it is a good idea for you....
hsroy79 and 3 other Camera and Video Specialists are ready to help you