How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask nathan_mills Your Own Question
nathan_mills
nathan_mills, Camera and Video Technician
Category: Camera and Video
Satisfied Customers: 640
Experience:  Efficient Technician with more than 30 years of Experience.
76814648
Type Your Camera and Video Question Here...
nathan_mills is online now

How do I save my pictures from a Fuji camera to my iMac with

Resolved Question:

How do I save my pictures from a Fuji camera to my iMac with OS X?How do I then save these pictures in an existing or newly created iMac album?Many thanks for your help, if possible.Paul
Submitted: 1 year ago.
Category: Camera and Video
Expert:  nathan_mills replied 1 year ago.
Hi. Welcome to justanswer.You the options to transfer images from your camera to your Mac via usb.You can connect your camera to iMac via usb cable and save photos. For that you need to install a software. CLICK HERE TO DOWNLOAD (Agree to the terms and conditions and download the file and run it to install it.)Reply if you have any query.Please rate the chat POSITIVELY so that I can get credited for my services. Thanks.
nathan_mills and 2 other Camera and Video Specialists are ready to help you
Customer: replied 1 year ago.
I downloaded the FPV36 Updater OK. However, when attempting to open this file FPVX365, I had the message " Power PC applications no longer supported", which prevented use.I am therefore no nearer solution. I know about the usb cable for camera iMac connection. But I get no apparent assistance with the import, storage into albums and file naming process, as provided on my old Microsoft PC.
Expert:  nathan_mills replied 1 year ago.
The problem is that Fujifilm has not release its software's updated version. And this version is not being supported by your Mac's OS as it must be higher than 10.6.
Customer: replied 1 year ago.
Hi Nathan,Thanks for your attempts to help. I will have to obtain the relevant expertise from another source, including Apple. I believe that we have now reached the end of the road with 'Just Answer'. I do not approve any service extension and related charges beyond this point in our discussion. Best Regards, Paul