How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JamesI Your Own Question
JamesI
JamesI, Handyman
Category: Appliance
Satisfied Customers: 3516
Experience:  I have repaired and maintained numerous items over the years, from fridges to freezers, radios to TV's.
75967336
Type Your Appliance Question Here...
JamesI is online now

I have a Freedom hoover. 394002273. Despite being charged

This answer was rated:

I have a Freedom hoover.###-##-#### Despite being charged the hoover has started to cut out after a few seconds. I have replaced the battery thinking it was that but it's still happening. I have looked for blockages but can't see anything and checked the filter which looks clean. Any suggestions!
Assistant: Can you guesstimate how old your Hoover is? And just to clarify, what's the exact model?
Customer: Freedom 22G - 001 - 39400273. I think it's about 2 years maybe 3.
Assistant: Do you plan on doing the work yourself?
Customer: Only if it's easily fixable. I just don't know why it's suddenly started cutting out after a couple of seconds. It then starts again for about as long. Then the red/blue light flashes intermittently.
Assistant: Anything else we should know to help you best?
Customer: No that's it! If it's a case of needing to replace the hoover which might be easier and possibly cheaper than repairing it I'm happy to do that. So a recommendation of what the latest similar Hoover model is

Hi, thank you for choosing Just Answer, my name is ***** ***** I will help with your query today.

Are you sure it charging up, are the relevant lights showing when it is charging?

Customer: replied 3 months ago.
it's red when charging. Blue when charged. After a couple of seconds it stops. The after another couple of seconds it stops again. After that the red light flashes with the blue light showing behind and the hoover doesn't work. Eventually it re-charges (I have a new battery in it - just purchased from Hoover) and then the same happens again. This has been for the last 2-3 weeks.
Customer: replied 3 months ago.
I'm not in a position to call or check at the moment. If you could give me the steps to follow and why it might be doing it that would be helpful.
Customer: replied 3 months ago.
I have the manual with the numbered steps and have followed all of them including the filter even though it looked very clean still. The bin is empty and there is nothing blocking the tubes.

Right this does point to a PCB fault which is what controls the motor.

Have you tried running it with the filter removed?

Customer: replied 3 months ago.
No James I haven't. Shall I try that?

Yes please, let me know if it runs without the filter or only for a few seconds.

Customer: replied 3 months ago.
Without the filter exactly the same happens. A couple of seconds and it's cut out. Red light on to recharge

Ok this point to a fault on the PCB then.

Customer: replied 3 months ago.
I've got a shop nearby which probably could repair but it might be cheaper to replace. I'll hqve to check the warranty docs.

I wouldnt look at repair if its not under warranty its cheaper to just replace.

Customer: replied 3 months ago.
At least I know what it is. Thanks
Customer: replied 3 months ago.
That's what I thought. Very helpful.

So I can mark the question as answered please rate the response using the star rating at the top of this page

JamesI and other Appliance Specialists are ready to help you