How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Rob Your Own Question
Rob
Rob, Home Appliance Technician
Category: Appliance
Satisfied Customers: 420
Experience:  20 yrs. experience with a major worldwide manufacturer.
14831508
Type Your Appliance Question Here...
Rob is online now

I have installed a new clock timer which is working

Customer Question

Hi I have installed a new clock timer which is working perfectly. But some reason both ovens have stopped working. No spark or gas smell from the oven.
JA: What's the brand and model of your oven? How old is it?
Customer: Rangemaster 110 leisure
JA: How long has this been going on with your Rangemaster oven? What have you tried so far?
Customer: i fixed the new clock two days ago and today tried to use the oven when I discovered the problem
JA: Anything else we should know to help you best?
Customer: not tha I can think of. I have checked and made sure to switch off the auto mode
Submitted: 12 days ago.
Category: Appliance
Expert:  Nicola-mod replied 11 days ago.
Hello,
I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.
I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.
Thank you!
Nicola
Expert:  JamesI replied 11 days ago.

Hi, thank you for choosing Just Answer, my name is***** see you raised the question some time ago, do you still require assistance?

Customer: replied 11 days ago.
please
Expert:  JamesI replied 10 days ago.

The clock will control the ovens, I assume you have set the time on the timer, and all wires are properly connected to the PCB?