How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Daniel Your Own Question
Daniel
Daniel, Home Appliance Technician
Category: Appliance
Satisfied Customers: 19037
Experience:  20+ yrs. experience in white goods repair. NVQ Level 2 electronics manufacturers training courses.
15468697
Type Your Appliance Question Here...
Daniel is online now

Beko washer dryer wdr854p141w no power at all. fuses checked

Customer Question

beko washer dryer wdr854p141w no power at all. fuses checked etc.
JA: Are you getting any error codes or messages from your Beko washer-dryer? How old is it?
Customer: i'm getting no lights on display at all
JA: How long has this been going on with your Beko washer-dryer? What have you tried so far?
Customer: Tried to turn on this morning - nothing worked. no previous problems prior to that
JA: Anything else we should know to help you best?
Customer: not really
Submitted: 13 days ago.
Category: Appliance
Expert:  Daniel replied 13 days ago.

Hi

 

Can you double check the model number please as the one you posted isnt bring anything up.

 

Thanks

Customer: replied 13 days ago.
WDR854P14N1W
Expert:  Daniel replied 13 days ago.

Thanks for that.

 

If nothing is comming up on the display and the power is fine then its more then likely the main power board.

 

If you remove the top panel you will see the main power board attached to the right hand side.

 

Make sure the power is off then remove the board and inspect it for burn marks as they do like to blow on these.

If you have a test meter you need to check you have 230v going into the washer at the back on the mains filter and if you do but nothing is coming on then im afraid it will be the main power board at fault here which will need to be replaced to cure this.