How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Erdal Zal Your Own Question
Erdal Zal
Erdal Zal,
Category: Appliance
Satisfied Customers: 2596
106347225
Type Your Appliance Question Here...
Erdal Zal is online now

FII code on dishwasher but no blockages found on drainage

Customer Question

FII code on dishwasher but no blockages found on drainage system - could it be that pump motor is faulty
JA: What's the brand and model of your dishwasher? How old is it?
Customer: Miele G1270SCV1 2006 model. As soon as pump starts the F11 light comes on. When drain pipe outlet is set at a lower level i.e. horizontal to the base of the machine, the F11 fault doesn't come on.
JA: How long has this been going on with your Miele dishwasher? What have you tried so far?
Customer: 2 weeks. disconnected drain pipe where it connects to kitchen sink drain - approx. 600mm above machine base, operated machine with drain outlet in a shallow basin on the floor, and the F11 fault didn't come on.
JA: Anything else we should know to help you best?
Customer: no
Submitted: 6 months ago.
Category: Appliance
Expert:  Erdal Zal replied 6 months ago.

Hello and welcome to JustAnswer. I would like to try to help you. I am an expert from Germany and work with language translators. I hope you will understand me.

Yes, the pump may be losing power. It may be that the pump is turning with difficulty. We have already written that if you put the hose in a horizontal position it will run better and the error message will not appear. If you replace the pump, these errors would not occur anymore. Have you cleaned the pump and the impeller of the pump and checked if it is not blocked and does not rotate smoothly?

Do you have any questions? I am waiting for your message. Greetings Erdal Zal

Customer: replied 6 months ago.
I have cleaned the pump impeller - it wasn't clogged, the inlet and outlet of the pump is clear - no debris. The impeller plastic fins are intact. They turn within an electromagnetic motor - the impeller doesn't turn freely by hand when machine is switched off the magnet still affecting its rotation?
Expert:  Erdal Zal replied 6 months ago.

The impeller must also be rotatable by hand. Not easy, but it must be possible to turn it by hand. I think if you replace the pump the unit will work properly again. Do you have any questions?

Expert:  Erdal Zal replied 6 months ago.

Do you have any more questions? May I help you? Wait for an answer.

Customer: replied 6 months ago.
The problem is that the pump works well on a 12 minute rinse cycle - water being emptied totally, but not on a 35 minute cycle It stops mid way through with the F11 warning coming on. Could it be a motherboard or control board fault? Can one override the F11 code and alarm, and thereby just continue with the cycle?
Expert:  Erdal Zal replied 6 months ago.

It is then either at the outlet hose still stiff or the pump is defective so that it becomes hot and runs slower.

Please check the drain hose.

I do not think the control is defective.
Do you still have questions?