How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask KevinWhiteJA Your Own Question
KevinWhiteJA
KevinWhiteJA, Home Appliance Technician
Category: Appliance
Satisfied Customers: 1926
Experience:  18+ years experience as Appliance Tech.
70193065
Type Your Appliance Question Here...
KevinWhiteJA is online now

Model T602CW. Runs cold even after changing heater element

Customer Question

Model T602CW. Runs cold even after changing heater element and thermostats.
JA: Who makes your heater? How old is it?
Customer: New genuine Creda part purchased from Random spares.
JA: How old is your Creda heater?
Customer: New genuine Creda Part purchased from Random Spares
JA: How long has this been going on with your Creda heater? What have you tried so far?
Customer: Fitted new heater and thermostats, cleaned all filters. No heat on any cycle.
JA: Anything else we should know to help you best?
Customer: Ran satisfactorily until this problem and still seems to run ok but no heat. Is it possible that the sensor unit in the drum ( connected to the band round the outside of the drum) could cause this fault?
Submitted: 15 days ago.
Category: Appliance
Expert:  KevinWhiteJA replied 15 days ago.

Hi,

Welcome to Justanswer … my name is Kevin and I will help you today!

I’m sorry to hear you're having trouble with your appliance; hopefully, we can get this resolved quickly.

 

Have you also checked the front thermostat with a multi-meter for continuity?

 

Please IGNORE the AUTOMATED PHONE CALL request.

Customer: replied 15 days ago.
Is that the round disc inside the drum which is attached to the strap on the outside of the drum- see my previous comment. If so, it only seems to have one output connection (the fixing screw).
Expert:  KevinWhiteJA replied 15 days ago.

No, its similar in appearance to the thermostats located at the back.

However, this thermostat is located at the front, check this IMAGE

Expert:  KevinWhiteJA replied 13 days ago.

Hi there, did that help ?

I still see the question is open so, wanted to check if all is good ?