How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Erdal Zal Your Own Question
Erdal Zal
Erdal Zal,
Category: Appliance
Satisfied Customers: 3916
106347225
Type Your Appliance Question Here...
Erdal Zal is online now

I have a Kenwood Prospero KM265. When using the food

This answer was rated:

Hi. I have a Kenwood Prospero KM265. When using the food processor attachment I have a problem with the unit cutting out. It can be used for several minutes without issue, turning the unit on and off and removing the lid as desired. However, there always comes a point where the unit will not start again. Usually I give up trying to turn back on and put it away and when you come back to it next time it works fine again. I have tested the operation of all the safety switches and the checked the lugs on the lid and bowl all are in good condition. Also checked the adjacent blender cover to check this has not been knocked during operation. All appears to be fine. Thinking this only happens when the units gets warm. Is there a thermal cut out switch which may be over sensitive? The unit is only slightly warm, not hot. Any suggestions? Thanks.
JA: How old is your Kenwood food processor?
Customer: 2007
JA: What have you tried so far with your Kenwood food processor?
Customer: Everything I mentioned above
JA: Anything else we should know to help you best?
Customer: no

Good Night

Welcome to JustAnswer and thank you for your question. My name is***** am an expert from Germany and have been working as an equipment technician for 19 years. I work with a language translation program and I would be very grateful for your understanding.
I'm sorry I can't make a call, but another expert can do it for you if you want. I will try to help you as best I can via chat.
I am sorry that you faced this problem!

With such devices and mixers, it is always advisable not to work for a long time on a tour. It has an overheating sensor that protects it does not burn or causes a defect in the engine. That is why it always switches off automatically depending on use and load. Can you tell me how long you use it before it turns itself off? Depending on the load, it should be able to run continuously for at least 3-8 minutes.

Please feel free to continue this topic if you have any further questions. I would be very happy to help you!
With best regards,
Erdal

Customer: replied 3 days ago.
Hi Erdal. Thanks for your reply. I was using the mixer intermittently. Approximately as follows: 30 secs use, 1 min rest, 1 min use, 1 min rest, 2 min use. I was using it to process cooked chick peas on around speed 3 to 4. It was after this sequence that I tried to use again but would not start. This has happened on several occasions doing this same process. The unit does not feel hot. Could the overheat sensor be too sensitive? Should I consider replacing the sensor? Thanks.

I had written to them that depending on the use, it can really be that the sensor activates a bit faster. But that is also OK for your device as a safety measure. The faster it denies that, the less likely it is that the motor will break. If it stops by itself in less than 30 seconds, you can consider replacing the sensor. It is still OK.

Erdal Zal and other Appliance Specialists are ready to help you
Customer: replied 3 days ago.
Ok Erdal. Thank you for your advice. I will try using the device keeping the load to a minimum. If the problem persists I will consider changing the sensor. Many thanks. Have a good evening.

Please I wish you the best of luck and success in doing so. You can write a message again at any time. I am always at your disposal. You can always take my help. You are always welcome to JustAnswer.co.uk