How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask KevinWhiteJA Your Own Question
KevinWhiteJA
KevinWhiteJA, Home Appliance Technician
Category: Appliance
Satisfied Customers: 5401
Experience:  18+ years experience as Appliance Tech.
70193065
Type Your Appliance Question Here...
KevinWhiteJA is online now

I have an American style Beko fridge/freezer (side by side).

Customer Question

Hi, I have an American style Beko fridge/freezer (side by side). The red exclamation mark has been on a few times in the last couple of days - I understand this is indicating temp issues.. the strange thing is that it will still freeze water to ice cubes but ice cream is turning to mush, indicating that it’s working to some degree but isn’t cold enough for ice cream? It’s set at -22, no ice build up. With the door shut it’s hard to hear whether the fans are working. With the door open the fans work when pressing the button.
JA: Do you know the model of your Beko fridge?
Customer: It’s a GL22APS
JA: How long has this been going on with your Beko refrigerator? What have you tried so far?
Customer: It’s been happening for a couple of days. Tried switching on and off, the warning light went out but is now back on. I’ve emptied the freezer to check for a ice build up - there is none
JA: Anything else we should know to help you best?
Customer: The fridge appears to be working properly, issues only with freezer at present.
Submitted: 13 days ago.
Category: Appliance
Expert:  KevinWhiteJA replied 13 days ago.

Good morning,

You have reached justanswer.co.uk, an independent paid question and answer platform that matches experts in various skills to customers.

My name is ***** ***** I will assist you with your appliance today.

I am sorry to hear you are having trouble with your appliance.

I understand how frustrating that can be.

If the door seal is fine then this indicates temperature issue and/or an air flow problem due to heavy ice build-up inside the rear wall of the appliance.

Please try this:

Leave it unplugged and empty with door open for around 24-36 hours.

Then plug it back (expect some water on the floor) and wait for another 8 hours so it gets back to optimum temperature.

The problem should be resolved.

However, if the issue appears again then the problem is with defrost operation.

You will have to test/replace the temperature sensor and/or defrost heater element to resolve the issue.

Please do not hesitate to ask any follow up questions.

I hope you enjoyed your experience with justanswer.co.uk today.

Have a wonderful day.

Thank you.