How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Erdal Zal Your Own Question
Erdal Zal
Erdal Zal,
Category: Appliance
Satisfied Customers: 4464
106347225
Type Your Appliance Question Here...
Erdal Zal is online now

I have a kenwood dishwasher model KID60S10 which doesn't

Customer Question

Hello there I have a kenwood dishwasher model KID60S10 which doesn't seem to be pumping water around the machine. It does fill with water and then there is a low humming noise when you'd expect the arms to start spinning and washing
JA: Are there any error codes or blinking lights on your Kenwood dishwasher? How old is it?
Customer: No I can't see any visible error codes, it's 6 years old
JA: How long has this been going on with your Kenwood dishwasher? What have you tried so far?
Customer: About 2 weeks, I have tried cleaning out the machine, I took the base off and measured the resistance across a couple of components, the water inlet valve, the small pump turbine thing and the motor, they all have reasonable resistance across them
JA: Anything else we should know to help you best?
Customer: No
Submitted: 15 days ago.
Category: Appliance
Expert:  Erdal Zal replied 15 days ago.

Good Evening

Welcome to JustAnswer and thank you for your question. My name is***** am an expert from Germany and have been working as an equipment technician for 19 years. I work with a language translation program and I would be very grateful for your understanding.
I'm sorry I can't make a call, but another expert can do it for you if you want. I will try to help you as best I can via chat.
I am sorry that you faced this problem!

If the machine feeds water into it and still does not pass the water on to the spray arm, then either the flushing pump is defective or blocked. You have to consider expanding it once. Here is a general video guide for you as an overview of what I would like to explain to you:

https://youtu.be/2KoxufSeeMQ

Please feel free to continue this topic if you have any further questions. I would be very happy to help you!
Kind regards,
Erdal

Customer: replied 15 days ago.
Hey I did check the resistance and it was higher then 100 ohms however I didn't take the motor off, I shall try that now and see if the blades rotate
Expert:  Erdal Zal replied 15 days ago.

It is very important that you check the pump to see if it can move freely. Please check it and write to me whether it is OK or not.