How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask James Your Own Question
James
James, Handyman
Category: Appliance
Satisfied Customers: 9447
Experience:  I have repaired and maintained numerous items over the years, from fridges to freezers, radios to TV's.
75967336
Type Your Appliance Question Here...
James is online now

I have just replaced the fan element in our Neff oven

Customer Question

I have just replaced the fan element in our Neff oven B1451W2GB/01but the element nor the fan now operate when switched on. Prior to replacing the elements both the fan and the grill still worked. What could it be please?
JA: Do you know the model of your Neff oven? How old is it?
Customer: 18 years old (2003) it’s a wall enclosed oven Model number as above
JA: How long has this been going on with your Neff oven? What have you tried so far?
Customer: Last week the fan worked but the element didn’t. I had the element checked and it was U/S.
JA: Anything else we should know to help you best?
Customer: No not without taken the oven out of its housing and opening up the rear.
Submitted: 10 days ago.
Category: Appliance
Expert:  James replied 10 days ago.

Hello and welcome to JustAnswer! This is James, I'm an appliance repair technician with over 10 years of experience, and I'll be assisting you today

Sorry to hear your appliance is having issues, please stand by while I find the answer for you, this is not an immediate service however I will try and respond as soon as possible.
What is the model number of your appliance?

Customer: replied 10 days ago.
Neff B1451 W2GB/01 wall mounted enclosed oven
Expert:  James replied 10 days ago.

Thank you for the model number, I would start by checking if you have power going to the terminals the common issue we see is where the wiring on the terminals has been incorrect fitted, or where the time has not been set on the clock or the overheat stat has failed.

It was a pleasure to assist you today. I hope the above answers the question. If you have any follow up questions then please let me know.