How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Erdal Zal Your Own Question
Erdal Zal
Erdal Zal,
Category: Appliance
Satisfied Customers: 5476
106347225
Type Your Appliance Question Here...
Erdal Zal is online now

I’ve got a Smeg TR93IP 90cm Victoria range coooker with

Customer Question

Hi. I’ve got a Smeg TR93IP 90cm Victoria range coooker with induction hob. A couple of the rings have stopped working properly. They heat up a little and then I hear electrical sparky type sounds and they turn off and flash. Some of the other rings still work fine.
JA: Do you know the model of your Smeg range? How old is it?
Customer: Smeg TR93IP Victoria.
JA: How long has this been going on with your Smeg range? What have you tried so far?
Customer: Only just happened in the last day. Not tried any fix yet.
JA: Anything else we should know to help you best?
Customer: No.
Submitted: 9 days ago.
Category: Appliance
Expert:  Erdal Zal replied 9 days ago.
Good Evening 

Welcome to JustAnswer and thank you for your question. My name is***** am an expert from Germany and have been working as an appliance technician for 20 years.

I work with a language translation program and would be very grateful for your understanding.

I'm sorry I can't talk on the phone, but another expert can do it for you if you wish. If you were to book the phone service, then you may have to wait a little while until another expert becomes free and accepts your phone request.

I will try to help you as much as possible via chat.

I am sorry that you are having this problem! Please give me a few minutes to check what kind of device you have and download the correct documents. If you have not written the model number or manufacturer please write it to me now.

I ask you now for a little patience.

Expert:  Erdal Zal replied 9 days ago.

They may have a faulty control board or the hobs may be faulty or defective depending on age and use. Have you already carried out a reset? If not, then paste this out once: You need to switch off the power supply from this hob for at least 30 minutes. The best way to do this is to switch off the power supply from the fuse box. Then switch it on and try it out.

Customer: replied 9 days ago.
Ok I will try the reset first and let you know b
Expert:  Erdal Zal replied 9 days ago.

Ok please good luck and success