How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike Your Own Question
Mike, Technician
Category: Audi
Satisfied Customers: 39198
Experience:  Tech Expert
Type Your Audi Question Here...
Mike is online now

instruments lights sometimes dont work when i switch on the

This answer was rated:

instruments lights sometimes dont work when i switch on the ignition

I've been working hard to find a Professional to assist you with your question, but sometimes finding the right Professional can take a little longer than expected.

I wonder whether you're ok with continuing to wait for an answer. If you are, please let me know and I will continue my search. If not, feel free to let me know and I will cancel this question for you.

Thank you,

Customer: replied 4 years ago.

what information do you need


No further information is required at the moment. I will continue to search for a Professional to assist you.

Customer: replied 4 years ago.
Relist: Other.
just want an answer?
Hello and Welcome..

My name isXXXXX happy to help you ..

I note your issues - Can you tell me - how intermittent is this...? And is it the same with whatever key you use?

Have you had any tests / checks done at all thus far?

Rgds, MIKE....................................
Customer: replied 4 years ago.

we just have the car two months now .it might be on if we go two the shop and when we come back out it might be of . this happens on and off we didnt try changing the key yet .but will try 2moro.we have no test yet as it is not due yet.

Hello again,

Thank you for your reply and info.


For some odd reason, your reply as above has only just reached me - That must have been a system issue of sorts, I can only apologise for that ..

Ok, What I meant by "test" was tests on the ign system, diagnostic wise - not Mot test..

Try the other key as I mention as this issue can sometimes be down to an electronic key problem... but if its not that, the actual wiring / connections need checking down from the back of the ignition unit to the fuse / relay box where they terminate. The actual fuses / relays should be checked there too for bad connections or even for water ingress which can happen sometimes.

Other than that as above if all is ok there - then the actual ignition unit is suspect given your symptoms as you describe them - before replacement I would advise have a garage check the system diagnostically as above to confirm that then go from there- they would do that with dedicated test equipment for the job -and one way or the other as above, that will see thus cured for you.

Do let me know if you need anything else at all -

Kind Rgds - MIKE.

...Meantime..............Please do click on the "OK/ Excellent ratings" for me as that's how Im credited for helping you - Thank you in advance for that...

You can and are most welcome to get back to me anytime you might need - clicking the OK ratings does not close you out at all..

Rgds, MIKE.

Mike, Technician
Category: Audi
Satisfied Customers: 39198
Experience: Tech Expert
Mike and other Audi Specialists are ready to help you