How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sebastian manrique Your Own Question
sebastian manrique
sebastian manrique, Auto Mechanic
Category: Audi
Satisfied Customers: 645
Experience:  Director Ejecutivo at Multiservicios Cruz de las Mercedes
100564933
Type Your Audi Question Here...
sebastian manrique is online now

I have a 2005 b7 Audi A4 2.0 tfsi that had a faulty tcm I

Customer Question

I have a 2005 b7 Audi A4 2.0 tfsi that had a faulty tcm I had the tcm repaired but now ever now and again the tcm losses all connection and the prnds on the dash disappears I’m getting the following codesENGINE:
1 Fault Found:
049409 - No Communication with Transmission Control Module
U0101 - 008 - Implausible Signal - Intermittent - MIL ONABS:
1 Fault Found:
01315 - Transmission Control Module
004 - No Signal/Communication - IntermittentI’m not sure if it’s a connection issue or a ground problem
Submitted: 9 days ago.
Category: Audi
Customer: replied 9 days ago.
When the prnds disappears the tranny seems like it’s in neutral and the esp light comes on either by itself or with a restart the prnds reappears and put it in drive the clutch slips before taking off
Expert:  sebastian manrique replied 9 days ago.
Hello, I'm Jose Sebastian. Your mechanic automotive expert, it's a pleasure to me to attend your question. Thank you very much for trust in just answer. Sorry for any delay.
Dear customer, have the wiring and wire loom been checked?
Customer: replied 9 days ago.
Not professionally is this something I can do
Expert:  sebastian manrique replied 9 days ago.

Dear customer, a revision of the wiring loom consists in dismantling all the wiring from the computer (TCM) to the sensors and connectors of the transmission box, this is to verify that you do not have physical problems of corrosion or broken wires that I am seeing the signal in the vehicle, I'm not sure if you have the knowledge to perform this process.
Another problem that I can recognize is that maybe the scanner is not having a good communication with the vehicle's computer so I would like to know the characteristics of the scanner if you can tell me please.

Customer: replied 9 days ago.
I’m using a vcds that belongs to my brother it may need an update
Expert:  sebastian manrique replied 8 days ago.

Dear customer, sorry for my delay.
First I recommend that you start with a computerized diagnosis with a more updatedcomputer becasue software problems can generate these types of codes, it turns out that the scanner detects that there is no communication in the systems is because thecar computers is more updated than the scanner so it does not have the propper software to access.

Do you understand me, dear client?

Customer: replied 8 days ago.
Hey mate I don’t have alot of spare cash to put into this car so getting the harness looked at by a diagnostic auto electrician is not an option So I’m trying to self diagnose the problem so I’m able to sell the vehicle where is the ground location that the tcm use?
Expert:  sebastian manrique replied 7 days ago.

Sorry for the delay, Dear customer.
No problem, although is a more difficult work we can do it by ourself.
What we are going to do is first review all the connectors of the ecu and the tcm, then you will follow that cable guide to where they reach their connectors, this way you will find both the masses how the different sensors of the vehicle, In any case the masses/grounds you will find it stuck to the chassis and the in the case/cover of the gearbox. but the ideal is to make a complete revision to the wire loom to rule out that the repaired tcm has not generated again a problem.
have you understood me dear customer?

Customer: replied 6 days ago.
No dramas what do you want me to do
Expert:  sebastian manrique replied 6 days ago.

Dear customer, first do you know where to find the tcm? if I'm not mistaken, it's on the passenger's side below the board

Customer: replied 6 days ago.
I’ve already had the tcm out before it’s a cvt 01J multitronic it’s located in the rear on the transmission. do you know the location of ground 83?
Expert:  sebastian manrique replied 6 days ago.

I don't have in my files the diagram of this model dear customer, soo i cannot indicate you with accuracy. But according to the fault we need to check all what i indicated you before starting from the TCM and following the wiring loom

Customer: replied 6 days ago.
No worries where do you want me to start at the tcm
Expert:  sebastian manrique replied 5 days ago.

Dear customer, you are going to disassemble the wire loom, do you understand me? I mean the wiring, remove and clean the tips and connectors, if you can replace them, only those that are sulfated or damaged( splitted, melted, burnt etc), When we have communication problems many times are problems in the connectors or in the wiring. We star following the loom from the TCM untill where it arrives to check it completely.
That's why i indicated that it is good to disassemble it, do you understand me?

Customer: replied 5 days ago.
I will start tomorrow at the tcm it’s got a 20 pin barrel connector the pins on the tcm look good but I can’t see inside the female connections to see wether or not they’re damaged is there a secret to it
Expert:  sebastian manrique replied 5 days ago.

Great dear customer, for this we need to be able to disassemble the whole TCM. Do you know how to do it?

Customer: replied 5 days ago.
Do you want me to take the tcm out of the transmission the tcm on my car is internal I know how to do it
Expert:  sebastian manrique replied 5 days ago.

Yes dear customer, I want you to verify the pins of the TCM and verify the board, you told me that the TCM went through a revision, I would like you to take advantage of it and verify it again

Customer: replied 5 days ago.
Ok I will inspect the pins
Expert:  sebastian manrique replied 5 days ago.

Great, i will be attentive.
Regards.

Customer: replied 10 hours ago.
Pins look fine connector look fine checked ground point cleaned it up got battery voltage at connector and the ground st the connector has little resistance checked resistance on the can high can low and I’m getting 58 ohms supposed to be 60 but pretty close. Perform a wiggle test the whole way along the loom and watch for dropouts but get nothing other than that I don’t know what I’m supposed to do should I send the tcm back