How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Philip Your Own Question
Philip
Philip, Car Enthusiast
Category: Car
Satisfied Customers: 65
Experience:  owner at point zero
106201380
Type Your Car Question Here...
Philip is online now

03 Berlingo Multispace - 12v aux sockets and nearside wing

This answer was rated:

Hi 03 Berlingo Multispace - 12v aux sockets and nearside wing mirror not working. Any thoughts?
JA: What is the make/model of your car?
Customer: Citroen Berlingo Multispace?
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Don't even know where to start, sorry.
JA: Have you checked the battery, particularly the terminal connections? Are they corroded?
Customer: Apologies; all the rest of the electrics fine and I have checked the fuses
JA: Anything else you want the mechanic to know before I connect you?
Customer: Don't think so

Hi - My name is ***** ***** I will try and assist you...

Have you been able yto locate the actual fuses for the 12V sockets and wing mirror ?

Customer: replied 11 months ago.
I think so; im not too bad at ready wiring diagrams
Customer: replied 11 months ago.
Sorry "reading" diagrams
Customer: replied 11 months ago.
not able to use my phone now
Customer: replied 11 months ago.
Hello?

No problem at all - :)

If you can possibly try and locate those fuses again using the FuseBox diagram - then simply replace them with another similar Amp fuse from another function that you know works (like radio or indicators etc) - Then if they work then you know its the fuse for sure as its not always evident just by looking at them i they work or not.

If you can try that and I will wait to assist you further . . .

Customer: replied 11 months ago.
Did replace fuses. No joy.

Ok - next thing you can try is to reset the ECU but disconnecting the battery - negative first then positive - wait a few minutes, then reconnect in reverse - positive then negative. Sometimes this resets a few little niggles...

Customer: replied 11 months ago.
OK, thanks for your info, I will have to try that later - at work just now.

No problem at all - here to help.

I will keep the case open and wait for your reply. Lets try and solve this thing :)

In the meantime please be so kind as to rate myself service.

Chat soon

Philip and other Car Specialists are ready to help you
Customer: replied 11 months ago.
HAve a good day

You too !