How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • Go back-and-forth until satisfied
    Rate the answer you receive.
Ask Gavin Perry Your Own Question
Gavin Perry
Gavin Perry,
Category: Car
Satisfied Customers: 366
Experience:  dasdasd
105804848
Type Your Car Question Here...
Gavin Perry is online now

I have an 09 VW Golf Mk5 thats failing to start, lights

This answer was rated:

Hi I have an 09 VW Golf Mk5 thats failing to start
JA: Will the headlights turn on? Is the battery fully charged?
Customer: lights radio and everything else work the car doesn't want to fire
JA: What is the model of your '09 VW?
Customer: Golf Match TDI 1.9
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: i have checked the oil and ive tried to check the wiring for the oil pressure sensor as thats the warnings light that appears
JA: Anything else you want the Mechanic to know before I connect you?
Customer: The same problem happened before, i took it to the garage, it was left over the weekend and the car started fine when they had a look at it?

Hi my name is Gavin can i help you with this ?

Customer: replied 14 days ago.
If possible yes!
Customer: replied 14 days ago.
what do you suggest i do?

Sounds like a solonoid issue with the starter motor are you confident around engines ?

Customer: replied 14 days ago.
fairly confident yes

Could you give the starter a bang for me ?

Customer: replied 14 days ago.
Still no luck, I get a low oil pressure turn engine off warning light on the dash

When did the oil warning light start happening.

and is the engine cranking over ?

Customer: replied 14 days ago.
The car stopped working mid drive, almost like id stalled, i then go into neutral, and turn the key to start the engine, the started motor runs, and it sounds like the engine is cranking over it simply won't fire, its after about 15 seconds of the oil pressure warning light comes on
Customer: replied 14 days ago.
i have plenty of oil in the car

They are a strong engine and is the timing belt up to date.

Customer: replied 14 days ago.
timing and cambelt were both replaced last year
Customer: replied 14 days ago.
Same issue happened to me earlier in the year, the car was left outside a garage over the weekend and when they came to look at it it worked fine

It will need a code read to see what is stored then.

Customer: replied 14 days ago.
It feels more like the engine has been immobilised than a mechanical fault

That is what i think hence needing a full code read.

Customer: replied 14 days ago.
Ok thank you for your help, i will see what i can find

Keep me posted and send me the codes when you have them regards Gavin.

Gavin Perry and other Car Specialists are ready to help you
Customer: replied 14 days ago.
Cheers